Form select does not operate if style sheet attribute overflow:auto applied to div

VERIFIED INVALID

Status

()

--
major
VERIFIED INVALID
18 years ago
4 years ago

People

(Reporter: ben.smith, Assigned: rods)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9+) Gecko/20010529
BuildID:    2001052904

When applying the style sheet attribute of overflow:auto to a div containing a
form select element (of default or size="1"), the form select will not expand
when a user tries to operate it, and can not select even the default selected
option in the select field. If the size is set to a number > 1, making it a
scrolling select field, the select operates correctly. If overflow is assigned
hidden or visible, the form select field works correctly.

Reproducible: Always
Steps to Reproduce:
1.Create Div to contain form
2.assign style="overflow:auto" to that div
3.place form elements, including <select> element with several options in form
4.select won't expand

Actual Results:  Select Box didn't expand and operate

Expected Results:  select box should expand and operate as typical, default
operation

Comment 1

17 years ago
Reporter Please attach a testcase

Comment 2

17 years ago
Marking INVALID the included page doesnt work and no testcase was attached.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
closing, ben.smith@habanero.com please reopen if the bug still occurs, and
please provide a testcase
Status: RESOLVED → VERIFIED

Comment 4

13 years ago
We found this bug appearing exactly as described in Netscape 7.0.  Due to the fact that we are developing intranet applications, we are unable to provide upgrades to the users stuck with 7.0.  

I don't know what I need to do to show you a test case, but this is certainly valid exactly as described.  Let me know if I can provide you with anything that will help you with this bug ( if anyone is even still tracking old 7.0 issues like this ).

Thanks,

Eric
You need to log in before you can comment on or make changes to this bug.