Viewer doesn't support recipient "groups" (RFC822)

VERIFIED DUPLICATE of bug 110605

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 110605
17 years ago
13 years ago

People

(Reporter: BenB, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From RFC2822, Section 3.4.:

group           =       display-name ":" [mailbox-list / CFWS] ";"
                        [CFWS]

[...]
   When it is desirable to treat several mailboxes as a single unit
   (i.e., in a distribution list), the group construct can be used.  The
   group construct allows the sender to indicate a named group of
   recipients. This is done by giving a display name for the group,
   followed by a colon, followed by a comma separated list of any number
   of mailboxes (including zero and one), and ending with a semicolon.
   Because the list of mailboxes can be empty, using the group construct
   is also a simple way to communicate to recipients that the message
   was sent to one or more named sets of recipients, without actually
   providing the individual mailbox address for each of those
   recipients.

Similar specs exist in RFC822.

We don't support them, at least not in the msg viewer. Note: This is a bug, not
an RFE. Supporting RFC822 is the most basic requirement for an email app.

I will file a separate bug to use groups for sending to lists (in Mozilla's
Address Book).

Reproduction (one possible - there are lots of reasons why I might see such
"groups"):
1. telnet your.smtp.server 25
2. Type

HELO a.domain
Mail FROM: <you@your.domain>
RCPT TO: <you@your.domain>
DATA
hello
.

2. Recieve mail with Mozilla
3. View the mail

Result:
This gives me a mail (msg source) like

Date: Thu, 31 May 2001 20:41:31 +0200
From: ben.bucksch@beonex.com
Message-Id: <foo@mailserver>
To: undisclosed-recipients: ;

hello

Actual result:
The To row in the Mazilla viewer shows

undisclosed-recipients:, ";"

while undisclosed-recipients: and ";" are separate addresses.

Expected result:
The To row in the Mazilla viewer shows

undisclosed-recipients

If the group is non-empty, we need to figure out a good display. Ccing Jen and mpt.
(Reporter)

Comment 1

17 years ago
Bug 83521 is about groups in the Composer / during send.
Keywords: mozilla1.0
Summary: Doesn't support recipient "groups" → Viewer doesn't support recipient "groups" (RFC822)

Comment 2

16 years ago
Does Group-Name <mailbox-list> looks bad?
If it's ok, then this bug can be fixed very easy (only address parsing
code must be aware of groups :-) ).
Otherwise notion of rfc822 group need to spread a bit wider.

Comment 3

16 years ago
This address:

    undisclosed-recipients:;

...is perfectly valid according to RFC822.  Mozilla must accept this construct
any place it would accept an address.  This means that Mozilla *must* permit
someone to compose a message to that address (see my 2002-01-17 comments on bug
83521).

It also means that Mozilla must properly deal with a received message that uses
the group construct..  E.g., displaying the above construct as:

    To: undisclosed-recipients:, ";"

...is not acceptable.  Replying to a message and having mozilla include the
string "undisclosed-recipients" as potential recipient is not acceptable.  (If
the group is null, then Mozilla should omit it; otherwise, it should preserve
the group syntax in the reply.)

Comment 4

16 years ago
Duping to bug 110605 which is already assigned.

pi

*** This bug has been marked as a duplicate of 110605 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.