Closed Bug 835161 Opened 7 years ago Closed 7 years ago

impossible to visit http version of google.com

Categories

(Firefox :: Untriaged, defect)

18 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 769994

People

(Reporter: james-bugzilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Visit www.google.com, and/or visit with protocol specified in URL http://www.google.com


Actual results:

Firefox chooses to go to https://www.google.com and does not attempt to retrieve http://www.google.com under any circumstances, even when protocol specified in URL. Obviously this doesn't work in cases where users have HTTP proxy only, or are encountering HTTPS proxy bug :)


Expected results:

Should go to http://www.google.com in cases where http is specified in URL at the very least. Possibly should have some option to disable the behaviour in advanced prefs.
should say, www.google.com is only an example, the one that I have come across when troubleshooting SSL proxy bug (835158)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
did you type the full http:// protocol in the locationbar, or just the www.domain.com? Cause the former should work.
bug 781617 in particular makes so that we respect what the user types, would be good to check if in this case is not google forcing a redirect rather than us (web console network log)
You need to log in before you can comment on or make changes to this bug.