Margin from incorrect class applied

RESOLVED DUPLICATE of bug 451791

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 451791
5 years ago
5 years ago

People

(Reporter: Brett, Unassigned)

Tracking

18 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Set a margin-top to a child element.


Actual results:

The margin gets applied to the child element (above the "featured stores" text) as well as the parent (main content container).


Expected results:

It should only be applied to the child element. I have attached a video that displays this in action & as you can see even Firebug agrees with me that there should be no margin up there. Additionally, margin doesn't get applied in IE or Chrome.
The attachment is missing and a testcase (attached or URL)
(Reporter)

Comment 2

5 years ago
Sorry, the attachment failed because of the large size & I didn't have time to upload it elsewhere.

Here is the video: http://www.condorstudios.com/stuff/temp/ff-margin.avi
Can you please attach a small html testcase that shows the issue ?

Updated

5 years ago
Component: Untriaged → Layout
Flags: needinfo?(gb3)
Product: Firefox → Core

Comment 4

5 years ago
Created attachment 710192 [details]
The screencast, converted into WebM
(Reporter)

Comment 5

5 years ago
Sorry, I will try & get a simple test case for you soon. Have been rather swamped working on projects.
Flags: needinfo?(gb3)
(Reporter)

Comment 6

5 years ago
Ok, I tried to come up with a simple test case but I was unable to reproduce the problem.
Brett, can you attach a non-simple test case?  But HTML, not video of HTML....
Flags: needinfo?(gb3)
(Reporter)

Comment 8

5 years ago
Hi Boris.... the site that this is from is still in development & isn't live right now. I fixed the problem by using padding instead, but when we launch the site (month or so) I will setup a page for you to check out.
Flags: needinfo?(gb3)
OK, thanks. Just comment here at that point, please.
Flags: needinfo?(gb3)
(Reporter)

Comment 10

5 years ago
Sorry I haven't gotten back on this, but I just noticed it again.

http://gimko dot com dot au/temp/

Notice the large margin at the top? That shouldn't be there and isn't shown when you view the page in Chrome.

If you right click the page and inspect the element - find the div with the ID of "main" and then disable the margin and you will notice the margin at the top of the page now vanishes.

Please let me know when you are done viewing the page so I can take it down.

Thanks!
Flags: needinfo?(gb3)
Brett, thank you for that testcase!  It's showing bug 451791, looks like: the margin of <div id="main"> is collapsing through the <div class="contentClear"> that's inside the header.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 451791
You need to log in before you can comment on or make changes to this bug.