Intermittent | | program error managing timeouts followed by 343087-1.html | load failed: null, 408753-1.xhtml | load failed: timed out waiting for test to complete (waiting for onload scripts to complete), 366556-1.xhtml | load failed: timed out waiting

RESOLVED FIXED in mozilla21

Status

()

Core
Layout
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: philor, Assigned: mats)

Tracking

({intermittent-failure})

Trunk
mozilla21
x86_64
Mac OS X
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
So far, the furthest back I've retriggered it into showing up is the bundle of added crashtests in https://tbpl.mozilla.org/?tree=Mozilla-Inbound&onlyunstarred=1&rev=a9e8397cd253

https://tbpl.mozilla.org/php/getParsedLog.php?id=19183267&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test crashtest on 2013-01-27 11:34:01 PST for push a9e8397cd253
slave: talos-r4-snow-067
REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/base/crashtests/374297-1.html | 791 / 2237 (35%)
REFTEST TEST-UNEXPECTED-FAIL | | program error managing timeouts
...
REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/tables/crashtests/343087-1.html | 1836 / 2237 (82%)
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/tables/crashtests/343087-1.html | load failed: null

https://tbpl.mozilla.org/php/getParsedLog.php?id=19170760&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test crashtest on 2013-01-26 13:45:38 PST for push 42ba5b4cf32a
slave: talos-r4-snow-076
REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/base/crashtests/374297-1.html | 791 / 2237 (35%)
REFTEST TEST-UNEXPECTED-FAIL | | program error managing timeouts
...
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/tables/crashtests/408753-1.xhtml | load failed: timed out waiting for test to complete (waiting for onload scripts to complete)

https://tbpl.mozilla.org/php/getParsedLog.php?id=19179931&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test crashtest on 2013-01-27 05:17:36 PST for push 6518cc9027e2
slave: talos-r4-snow-053
REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/base/crashtests/374297-1.html | 791 / 2237 (35%)
REFTEST TEST-UNEXPECTED-FAIL | | program error managing timeouts
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/tables/crashtests/366556-1.xhtml | load failed: timed out waiting for reftest-wait to be removed

Not sure what it means that all three have been on 10.6 debug, or that the timeout failure is always after 374297-1.html starts, but the other failure is always in a different test - 374297-1.html is not at all new, but both of the big chunks of crashtests mats added yesterday (https://tbpl.mozilla.org/?tree=Mozilla-Inbound&onlyunstarred=1&rev=a9e8397cd253 and https://tbpl.mozilla.org/?tree=Mozilla-Inbound&onlyunstarred=1&rev=ccbdf81cfb73)were in the 300Ks, so about 75% of them would be running somewhere before it.
(Assignee)

Comment 1

5 years ago
A few of those new crash tests had "onload" stuff that probably needs a
"reftest-wait", I've pushed this correction:
https://hg.mozilla.org/integration/mozilla-inbound/rev/409c4b5a6c83
(Reporter)

Comment 2

5 years ago
https://hg.mozilla.org/mozilla-central/rev/409c4b5a6c83
Assignee: nobody → matspal
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
(Reporter)

Comment 3

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=19206383&tree=Mozilla-Inbound

REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/base/crashtests/374297-1.html | 791 / 2237 (35%)
REFTEST TEST-UNEXPECTED-FAIL | | program error managing timeouts
...
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/tables/crashtests/370897-1.html | load failed: null
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 4

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=19207871&tree=Mozilla-Inbound

REFTEST TEST-START | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/base/crashtests/374297-1.html | 791 / 2237 (35%)
REFTEST TEST-UNEXPECTED-FAIL | | program error managing timeouts
...
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/test/build/reftest/tests/layout/tables/crashtests/358679-1.xhtml | load failed: null
(Assignee)

Comment 6

5 years ago
I'm guessing the problem is the window.location.reload() in 373628.html which is
one of the crash tests I added recently.  I wrapped the test inside an <iframe>
and limited the time it runs, hope this helps:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc68bddecb56
(Assignee)

Comment 8

5 years ago
Looks like it was fixed.  Please file new bugs if there are further problems.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.