Closed Bug 835175 Opened 9 years ago Closed 9 years ago

Work - Synthetic mouse clicks from touch events fall through appbar and flyouts, into content

Categories

(Firefox for Metro Graveyard :: Browser, defect)

All
Windows 8.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bbondy, Assigned: mbrubeck)

References

Details

(Keywords: regression, Whiteboard: feature=work)

Attachments

(1 file)

Mouse clicks on the appbar currently fall through into the content.  That shouldn't happen.  Position a link or button underneath the appbar.  Click the appbar.  It loads the page on the link you clicked.
This is affecting other elements too, like the <flyoutpanel>s.  It happens only for our synthetic mouse events generated by tapping.  Clicks from "real" mouse input work correctly.
Blocks: 831955
Summary: Moue clicks on appbar fall through into content → Synthetic mouse clicks from touch events fall through appbar and flyouts, into content
Summary: Synthetic mouse clicks from touch events fall through appbar and flyouts, into content → Work - Synthetic mouse clicks from touch events fall through appbar and flyouts, into content
Whiteboard: [metro-mvp] → feature=work
This is caused by ui.mouse.radius.enabled (bug 788109, bug 780847).  We need to make sure it doesn't select a target that's covered by another element.
Assignee: nobody → mbrubeck
Blocks: 780847
Keywords: regression
Attached patch band-aidSplinter Review
This works around the problem for our <appbar> and <flyoutpanel> elements, since  FindFrameTargetedByInputEvent will never re-target an event if the original target has a click handler.

I'll file a separate bug for the underlying platform issue.
Attachment #709207 - Flags: review?(jmathies)
Attachment #709207 - Flags: review?(jmathies) → review+
http://hg.mozilla.org/projects/elm/rev/790dedff21e9

Filed bug 837242 for the root issue.
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 837242
Hardware: x86_64 → All
Resolution: --- → FIXED
Blocks: 788109
No longer blocks: 780847
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.