Closed Bug 835264 Opened 10 years ago Closed 7 years ago

[ko] Add Nanum font to show Korean character in Firefox OS

Categories

(Mozilla Localizations :: ko / Korean, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1074022

People

(Reporter: channy, Assigned: hyeonseok)

References

Details

Attachments

(1 file)

Just note there's already Korean font in Firefox OS.
Another method of this issue is to distribute own add-on as like https://addons.mozilla.org/ko/firefox/addon/khmer-fonts-package/
We need to make sure fontconfig is properly set up so CJK characters/punctuations will use the font of the language if "lang" attribute is correctly specified.
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #3)
> We need to make sure fontconfig is properly set up so CJK
> characters/punctuations will use the font of the language if "lang"
> attribute is correctly specified.

Is there any possibility to add CJK specific fonts?
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #3)
> We need to make sure fontconfig is properly set up so CJK
> characters/punctuations will use the font of the language if "lang"
> attribute is correctly specified.

Configuration of Nanum fonts are already in upstream fontconfig project.
So, I guess most Linux distros include configuration.

https://bugs.freedesktop.org/42423
http://cgit.freedesktop.org/fontconfig/tree/conf.d/40-nonlatin.conf
http://cgit.freedesktop.org/fontconfig/tree/conf.d/65-nonlatin.conf

In Android, there's little modifications of Nanum fonts.
https://android.googlesource.com/platform/external/naver-fonts/+/master/README
https://android.googlesource.com/platform/frameworks/base/+/master/data/fonts/fallback_fonts.xml

Nanum is series of several fonts published by NHN and released under SIL Open Font License, Version 1.1.
http://hangul.naver.com/font (Korean link)
http://help.naver.com/ops/step2/faq.nhn?faqId=15879 (License link, also Korean)

But I think 2~3 fonts is only important - NanumGothic(Sans), NanumMyeongjo(Serif), NanumGothicCoding(Mono)
These fonts include Japanese characters(Hiragana/Katakana) and ~5000 Chinese characters(Traditional).

One different thing is in Nanum fonts, backslash(\) character is Korean currency symbol(₩) as Windows XP fonts did.

(In reply to Channy Yun [:channy] from comment #4)
> (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #3)
> > We need to make sure fontconfig is properly set up so CJK
> > characters/punctuations will use the font of the language if "lang"
> > attribute is correctly specified.
> 
> Is there any possibility to add CJK specific fonts?

Also, I'd like to know if there are any plan to support CJK characters in MozTT.
Tim, we want to add NanumGothic as a Korean display font. Please guide for us. If we do, the basic jobs will be ended for Korean release.
android uses https://android.googlesource.com/platform/external/naver-fonts/.  So we should add manifest.xml to this, then use it.
Naver released new font named NanumBarunGothic(나눔바른고딕) which is optimized for mobile few month ago.
And they lately confirms it's also released under SIL OFL.
I think we should consider using NanumBarunGothic instead of NanumGothic.
Attachment #8351540 - Flags: review?(mwu)
I would prefer adding these fonts via the manifest at https://github.com/mozilla-b2g/b2g-manifest/blob/master/base-jb.xml rather than moztt, if we're ok with using NanumGothic. This means that devices based on ICS won't get these fonts, but those devices are mostly low on flash space anyway and we don't want to add any more fonts there if we don't need to.

Note that JB and newer releases should have the Nanum fonts from the naver-fonts repo, but we should update our own manifests to reflect what shows up on real devices.
(In reply to Jinkyu Yi[:jincreator] from comment #5)

> One different thing is in Nanum fonts, backslash(\) character is Korean
> currency symbol(₩) as Windows XP fonts did.

This is regrettable - it encourages the continued use of obsolete, non-Unicode-compliant encoding. The Won currency symbol is U+20A9 (which is also supported, with an identical glyph, in NanumGothic), or there's also the Fullwidth variant at U+FFE6; but U+005C should be kept as the backslash.

How widespread is the use of the backslash character code in place of the Won currency sign? I tried randomly browsing a few Korean shopping sites but didn't notice this being used.

It would be preferable, IMO, if we could avoid shipping fonts that include such encoding hacks. Encouraging the use of standard, interoperable Unicode everywhere is better for the health of the entire Web.
Do you want to try fixing the font, then?

There's also Nanum Barun Gothic, which is in beta afaict. Maybe we can ask them to fix it there? FWIW, I think Dave Crossland also plans to put Nanum Barun Gothic in google fonts.
Comment on attachment 8351540 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/moztt/pull/23

Clearing review because I think we would want to either add the nanum font repo to the manifest, which would reflect what vendors actually ship, or add a font that addresses jfkthame's concerns and ask our vendors to not ship nanum. In either case, we shouldn't add this font as is to moztt.
Attachment #8351540 - Flags: review?(mwu)
Ideally, we should try to convince the creators of the Nanum fonts to stop doing this non-Unicode-compliant hack of mapping the backslash character to a ₩ glyph, and replace it with a standard backslash.

However, the naver.com site appears to be only in Korean, which makes it difficult for me as a non-Korean-speaker to follow up on this. Could one of you (Jinkyu? Channy?) try contacting them and see if there's any possibility of getting this changed?

An alternative would be for us to fork one of the Nanum fonts and replace the glyph in our version, and then ship this in FxOS. If this is wanted, I'll attach a "fixed" font here for testing. But it'd be preferable to avoid this and encourage the Korean computing world as a whole to adhere more closely to the Unicode standard.
I contacted Naver directly and will follow up the result from Naver.
FYI,

There is alternative to choose Google's Noto Fonts.
http://www.google.com/get/noto/#/family/noto-sans-kore
Is there any plan to adopt them in Firefox OS?

They are originated by Adobe and Google's co-work for Open CJK integrated fonts project.
http://blog.typekit.com/alternate/source-han-sans-jp/
http://blog.typekit.com/alternate/source-han-sans-kor/
Channy and all,

It seems we don't have any progress for quite long time.
And while, Adobe and Google release new fonts which can cover CJK and more.
So, I suggest close this bug, open new bug discussing about using Source Sans Hans(Noto Sans CJK) and CC CJK users.
Depends on: 1074022
(In reply to Jinkyu Yi[:jincreator] from comment #17)
> Channy and all,
> 
> It seems we don't have any progress for quite long time.
> And while, Adobe and Google release new fonts which can cover CJK and more.
> So, I suggest close this bug, open new bug discussing about using Source
> Sans Hans(Noto Sans CJK) and CC CJK users.

Using Source Han Sans sounds like an excellent idea! Logged a separate bug, as it will affect all CJK locales.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074022
You need to log in before you can comment on or make changes to this bug.