If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

bottom property handled wrong for fixed positioning

RESOLVED FIXED

Status

()

Core
Layout
--
major
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: nemo, Assigned: dbaron)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20 i686; en-US; rv:0.9+)
Gecko/20010530
BuildID:    2001053008

The linked page has 3 style sheets:
Default uses "position: fixed" in combination with "bottom:"
working uses "bottom:" only.
absolute positioning uses "position: absolute" and "bottom:"

With default, the sample text does not appear at all.
With working, it appears, but is not positioned relative to bottom.
With absolute positioning, it appears, but does not follow the page as it
scrolls (while text positioned against the top does)

Reproducible: Always
Steps to Reproduce:
1.Visit the site
2.Select View->Use Stylesheet->Default/working/absolute positioning
3.Note the absence or odd positioning of the phrase "This should show!!
"


Expected Results:  Difficult to say.  At the very least, bottom: should work the
same as top: does, and definitely the text should not disappear completely.
Therefore, I was expecting the text to remain in the same position as I scroll,
relative to the edges of the window.
However, IE5 (Sparc version) merely places it at the very bottom of the page
(not window) using either absolute or fixed or neither.

Comment 1

17 years ago
confirming, cvs linux from today.

cc: dbaron who showed some interest on irc
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

17 years ago
Clarification, sorry for the confusion
Absolute: in fact, works fine.
Fixed: however, does not display anything.  The menu disappears.

Giving no position: tag causes top: bottom: etc to be ignored, this in fact may
be perfectly alright.  

So, I changed the title. :)

Again, apologies for filing it before properly understanding how it worked.
BTW, part of the confusion was due to the w3.org page I used specifying both
position types for earlier browser compatibility.
However the windows machine with IE5 that I was also testing on merely got
confused when this was done (it still couldn't handle "fixed" but would not do
"absolute" when followed by a "fixed")
Summary: 3 handlings of "bottom:" tag in CSS, all incorrect → handling of "bottom:" tag when using fixed positioning incorrect
This should be in Layout.
Assignee: pierre → karnaze
Component: Style System → Layout
QA Contact: ian → petersen
Summary: handling of "bottom:" tag when using fixed positioning incorrect → bottom property handled wrong for fixed positioning
I can't access the test case, not sure why. Can someone post it as an attachment?
(Reporter)

Comment 5

17 years ago
Created attachment 38830 [details]
1 of 3 css files for trying handlings of position tag
(Reporter)

Comment 6

17 years ago
Created attachment 38831 [details]
2 of 3, css...
(Reporter)

Comment 7

17 years ago
Created attachment 38832 [details]
3 of 3. sorry for the multiple e-mails, the standard *does* support sending more then one file at a time, pity bugzilla doesn't.
(Reporter)

Comment 8

17 years ago
Created attachment 38833 [details]
and finally, the html.

Comment 9

17 years ago
reporter: please change the css file name to showattachment.cgi?attach_id=38832
or something similar. otherwise the html references a file that does not exist.
(Reporter)

Comment 10

17 years ago
Created attachment 38952 [details]
for those who can neither access the url, or were too lazy to d/l the above 3 attachments, this html uses bugzilla links for its css
Created attachment 38994 [details]
Simplified test case
"top" works but "bottom" doesn't. Interesting. Shouldn't be hard to fix.
This does work for me with a build of a few days ago.
I fixed this on bug 98579 (I forgot about this bug).
Assignee: karnaze → dbaron
Fix for bug 98579 checked in 2001-09-17 16:55 PDT.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.