[app][maps] When switches from Maps to other apps and comes back, Maps app shouldn't be reset

RESOLVED INVALID

Status

Firefox OS
Gaia
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: pabloUX, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: interaction, UX-P1, TEF_REQ)

(Reporter)

Description

5 years ago
when going from the maps to a website for a business (from maps app to browser) and returning to the maps app from the browser : 
 - user is asked again is they wish to share their location.
 - if the user searchs before going to the browser when the user returns and seaks directions the map app forgets their search and searchs from 'current location'

(if you need more info, please ask aymanmaat@hotmail.com)

Updated

5 years ago
Blocks: 837298

Comment 1

5 years ago
issue 1 is a platform issue

issue 2 is probably just due to the fact that the maps app was closed by the system when you started browsing and consuming too much memory. when you returned to the maps app, the app was restarted.
(In reply to AndyT from comment #1)
> issue 1 is a platform issue

Issue 1 actually is by design for how cookie jars work.

> 
> issue 2 is probably just due to the fact that the maps app was closed by the
> system when you started browsing and consuming too much memory. when you
> returned to the maps app, the app was restarted.

Sounds a classic we ran out of memory, killed the process, and it restarted. Also expected behavior.
No longer blocks: 837298
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.