If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[EMAIL] The search filters are not working correctly

RESOLVED DUPLICATE of bug 833213

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 833213
5 years ago
5 years ago

People

(Reporter: maat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: interaction [UX-P1], [TEF_REQ], PRODUCT-FIXFEATURE)

(Reporter)

Description

5 years ago
[EMAIL] The search filters are not working correctly

**DESCRIPTION**
The search filters are not working correctly

**PATH**
1) open the email app
2) enter the search facility either by tapping on the search icon or tapping on the search text field
3) start to type


**EXPECTED**
For each filter results will automatically be generated with the section of the result that correlates to the string in the search field highlighted

**ACTUAL**
 
__ From filter __
seems to be working ok


__ To filter __
Search results returned, but the section of the results that correlates to the string in the search field is not displayed in the results, therefore nothing is  highlighted and without clicking on each result and investigating the end user has no idea of why a result is relevant to their search criteria.

__ Subject filter __
No search results are returned. ever.


__ Body __
seems to be working ok

__ All __
No search results are returned. ever.

Having a fully functional and communicating filtering system on the search facility in the email app is integral to the end users perception of value in the app and therefore the app's viability. It would folly to launch the app with either a malfunctioning or mis communicating search facility.

[TEF_REQ] as fully functional and communicating search facility is required for TEF build.
(Reporter)

Updated

5 years ago
Component: General → Gaia::E-Mail
QA Contact: nhirata.bugzilla
Whiteboard: interaction [UX-P1], [TEF_REQ]
Hm; there is clearly something intermittently weird happening on search. Bug 833213 was filed and retracted on subject and all searches (possibly because of the subject logic) as well.  I'm expecting a logcat is coming privately, but for search problems we also really want the exact text string that was searched for and an exact example of the text with accents/whitespace that it was expected to match against.  (From Thunderbird, I frequently found that people were filing bugs relating to search that involved accent characters or whitespace that were key to the bug, so it's important to know.  Since we don't have a 'view source', whitespace problems might not be obvious, however.)

Updated

5 years ago
Whiteboard: interaction [UX-P1], [TEF_REQ] → interaction [UX-P1], [TEF_REQ], PRODUCT-FIXFEATURE
Bug 833213 came back to life and I figured out what the problem with the assistance of the logcat on there.  This bug is the same as that bug, but I'm not sure what to do dupe-wise since I may be able to get tef+ on this but can probably get leo+ on that bug.

The problem seems to be having a message with an empty subject.
Duping to bug 833213 after all; I've marked it tef? and have noted the current whiteboard flags on here, but have not propagated the flags since Ayman indicated he is willing to do that when it seems appropriate.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 833213
You need to log in before you can comment on or make changes to this bug.