Browser segfaults in nsFrame

VERIFIED WORKSFORME

Status

()

Core
Layout
--
critical
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: km, Assigned: karnaze (gone))

Tracking

({crash})

Trunk
Sun
Solaris
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This happens by going to http://www.kcrw.com amd selecting the
"simulcast" link near the top left. The browsser seg faults
following the link to /www.kcrw.com/grid, although this does not
happen if you go there directly.

I've seen this on Solaris, Linux and Windows for some time including
the current daily (at least on Solaris) 20010530..

The backtrace always ends in nsFrame.
could you attach the backtrace?
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 2

17 years ago
Created attachment 36748 [details]
backtrace for segfault

Comment 3

17 years ago
over to Layout.
Assignee: asa → karnaze
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 4

17 years ago
can you print mFrame? [it really shouldn't be null because that's checked, but 
it might be garbage]
1651   if (!mFrame)
1652     return NS_ERROR_FAILURE;
1654   nsCOMPtr<nsIPresContext> pc(do_QueryInterface(aContext));
1656   NS_ASSERTION(pc, "not a pres context!");
1658   return mFrame->FrameChanged(aContainer, pc, newframe, dirtyRect);

Comment 5

17 years ago
Worksforme with a build fmr 06-02
(Assignee)

Comment 6

17 years ago
I'm not seeing the problem on 6/4/1 Win2K. Can someone please verify if this is 
still a problem on Solaris or Linux.

Comment 7

17 years ago
this was fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
rs vrfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.