[music] music playback and video recording issues

VERIFIED FIXED in B2G C4 (2jan on)

Status

Firefox OS
Gaia::Music
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: Inder, Assigned: mchen)

Tracking

unspecified
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

(Whiteboard: [CR 444261])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
There are two issues I am seeing right now with music play back and video recording:
a) Music playback doesn't stop when playing the recorded video.
STR:
1. Open music app and play a song
2. Switch to gallery and play a recorded video
3. Music and recorded video playback happen simultaneously.
NOTE: This should have been fixed by bug 821627 but that didn't happen.

b) Music playback doesn't stop when recording a video through camcorder.
STR:
1. Open music app and play a song
2. Switch to camera app and camcorder mode
3. Start to record a video.

Actual Result:
Music playback doesn't stop. In fact, the playback starts playing through external speaker if headphone is plugged in!
Stop recording and music playback also stops!

Expected Result:
Music playback should stop when recording is started and resumed when recording stops.
NOTE: Let me know if separate bugs need to be filed for these cases. I am thinking that they very related so can be fixed through same bug.
(Reporter)

Updated

6 years ago
blocking-b2g: --- → tef?
Hi Inder, 
Could you provide the test rom version?
(Reporter)

Comment 2

6 years ago
(In reply to Randy Lin [:rlin] from comment #1)
> Hi Inder, 
> Could you provide the test rom version?
Sorry, not sure what you mean by that.
(Assignee)

Comment 3

6 years ago
Created attachment 707517 [details] [diff] [review]
Patch v1

The root cause is that
  AudioChannelService didn't call notify() to ask other agents call getMuted() again when someone's (agent) visibility is changed. This is needed by content channel because the visibility change will effect other content channel's (they can be in different process) mute status.
Assignee: nobody → mchen
Attachment #707517 - Flags: review?(amarchesini)
(Assignee)

Updated

6 years ago
Blocks: 835737
Comment on attachment 707517 [details] [diff] [review]
Patch v1

Review of attachment 707517 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/audiochannel/AudioChannelService.cpp
@@ +192,5 @@
>             mChannelCounters[AUDIO_CHANNEL_INT_CONTENT].IsEmpty()) {
>      mActiveContentChildIDsFrozen = true;
>    }
>  
> +  if (newType != oldType && aType == AUDIO_CHANNEL_CONTENT) {

probably we can just say:

if (newType != oldType) {
  Notify();
}
Attachment #707517 - Flags: review?(amarchesini) → review+
blocking-b2g: tef? → tef+
Duplicate of this bug: 833244
(Assignee)

Comment 6

6 years ago
(In reply to Andrea Marchesini (:baku) from comment #4)
> > +  if (newType != oldType && aType == AUDIO_CHANNEL_CONTENT) {
> 
> probably we can just say:
> 
> if (newType != oldType) {
>   Notify();
> }

Hi Andrea,

Thanks for your suggestion first.
And channel types except the content type don't effect the status of mute when their visibility is changed. So I limited to fire notify() only when content channel's visibility is changed. This can reduce the calling times of GetMuted() from childs.
(Assignee)

Comment 7

6 years ago
Created attachment 707958 [details] [diff] [review]
Patch Checkin-Version

Add reviewer and a=tef+.

Wait for try result.
https://tbpl.mozilla.org/?tree=Try&rev=2cff72efa3cc
Attachment #707517 - Attachment is obsolete: true
Attachment #707958 - Flags: review+
Marking status-b2g18 and status-b2g18-v1.0.0 as affected, please update the status to fixed once this is verified landed on v1-train/mozilla-b2g18 and v1.0.0/mozilla-b2g18_v_1_0_0
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → affected
(Assignee)

Comment 9

6 years ago
Try is all green. Set checkin-needed.
Keywords: checkin-needed
Should this patch land to some other repository?

Updated

6 years ago
Blocks: 832846

Updated

6 years ago
No longer blocks: 832846

Updated

6 years ago
Blocks: 835232
https://hg.mozilla.org/mozilla-central/rev/d7fd7fc444f6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → B2G C4 (2jan on)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #13)
> https://hg.mozilla.org/mozilla-central/rev/d7fd7fc444f6

Are you going to uplift this patch to gecko-18 and v1.0.0?
(Assignee)

Comment 15

5 years ago
(In reply to John Ford [:jhford] from comment #14)
> (In reply to Ryan VanderMeulen [:RyanVM] from comment #13)
> > https://hg.mozilla.org/mozilla-central/rev/d7fd7fc444f6
> 
> Are you going to uplift this patch to gecko-18 and v1.0.0?

Please refer to comment 10, Andrea already help to do this.
(In reply to Marco Chen [:mchen] from comment #15)
> Please refer to comment 10, Andrea already help to do this.

Missed that, and the flags weren't set to fixed for status-b2g18 and status-b2g18-v1.0.0.  I'll set those flags now.
status-b2g18: affected → fixed
status-b2g18-v1.0.0: affected → fixed

Comment 17

5 years ago
Verified issue no longer repros on Unagi
    
Build ID 20130214070203
Kernel Dec 5
Gecko:http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/d1288313218e
Gaia: 6544fdb8dddc56f1aefe94482402488c89eeec49
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.