Localized "complete" and "failed" strings are not used in BT file transfer notification status

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: tchevalier, Assigned: iliu)

Tracking

({l12y})

unspecified
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(3 attachments)

When a Bluetooth file transfer finished, the notification displayed at the top of the screen (the string is bluetooth-file-transfer-result in system.properties) is localized, but not the {{status}} variable in it.
Verified in French when the status is "complete".

I got "complete du transfert de fichier par Bluetooth."
Instead of "Réussite du transfert de fichier par Bluetooth."
Keywords: l12y
blocking-b2g: --- → leo?
Does this happen with leo shipping languages too or just in French (which we believe is not a v1.1 shipped locale)?
Keywords: qawanted

Comment 2

6 years ago
(In reply to lsblakk@mozilla.com from comment #1)
> Does this happen with leo shipping languages too or just in French (which we
> believe is not a v1.1 shipped locale)?

For clarification, this would be blocking-b2g- if it only affected French (French isn't a v1.0.1/v1.1 locale)
Delphine, I will try again with another locale once I receive the phone (maybe it is fixed since I opened the bug). But feel free to verify first if it take too much time.
Investigating at the moment:
https://github.com/mozilla-b2g/gaia/blob/v1-train/apps/system/locales/system.fr.properties#L192

Spanish should show it at the end : 
https://hg.mozilla.org/gaia-l10n/es/file/0fc4d28a3269/apps/system/system.properties#l216

as well as pt_BR:
https://hg.mozilla.org/gaia-l10n/pt-BR/file/55c0026a906a/apps/system/system.properties#l214

Looks like they are all using {{status}} which should be translated for complete and failed in the following 2 lines.
QA Contact: wachen → nhirata.bugzilla
Created attachment 730744 [details]
screenshot

Spanish should be "completada" not "complete".

I believe this affects all languages.  There are other things notifications that are not getting translated as well for bluetooth.
Created attachment 730746 [details]
notification screenshot not translated

https://hg.mozilla.org/gaia-l10n/es/file/0fc4d28a3269/apps/system/system.properties#l199  

shows that it should be translated.  [Side note: t is missing in the spanish translation.  See the line.]
[side note : Filed bug 855755 for the missing t.]
Forgot to list what I was testing on:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/879324d41588
Gaia   e7e7c1a473b4069544f2dad779b1c9b1bab91663
BuildID 20130327070202
Version 18.0
Unagi

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/c516d7e67150
Gaia   d40dcdd112f12e2a5a0d1de46451670918fd4369
BuildID 20130328070202
Version 18.0
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected
triage: leo+ as the word seem to have missed to be translated in multiple languages
blocking-b2g: leo? → leo+
(Assignee)

Updated

6 years ago
Assignee: nobody → iliu

Comment 10

6 years ago
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/bluetooth_transfer.js#L361 is the code in question, that doesn't _() the status itself.

Given that the strings exist, they'd only be exposed newly. I don't think we're loosing any testing knowledge by exposing them now.

Thus no late-l10n, but it is l12y.

Technically, we could take a patch for 1.0.1, too, IMHO. Just saying.
Ian-Liu, please let me review this one. :-)
Created attachment 732677 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8956

Pointer to Github pull-request
Comment on attachment 732677 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8956

Add localized method for the status string.

Kaze,
Thanks for reviewing my pr.
Attachment #732677 - Flags: review?(kaze)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Uplifted commit 899af387a9be0f94f9f68b0c51714ca3de518225 as:
v1-train: 0a44b3de3d9c550f5bb520d04721fc8120eabc2d
status-b2g18: affected → fixed
Can we take this on 1.0.1 as well?
Not a blocking issue, but cannot localize well.
Nominating tef+..
blocking-b2g: leo+ → tef?
(Assignee)

Updated

6 years ago
Duplicate of this bug: 837484

Updated

6 years ago
blocking-b2g: tef? → tef+
v1.0.1: 6b4e3334ae59b0bee461721022bf6e5a8ce69441
status-b2g18-v1.0.1: affected → fixed
Duplicate of this bug: 853968
Duplicate of this bug: 853967
Verified fixed on inari device with:

Gaia   34ceae4e9b32231461804d37fb5f1c49f54fcf86
BuildID 20130417003914
Version 18.0

from v1.0.1 branch
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.