[B2G][Settings] Display: Brightness does not adjust as the slider is being moved.

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
P1
normal
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: Darren, Assigned: scottwu)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Repro Steps:
1. Load the Unagi build 20130128070201.
2. Open the Settings app.
3. Select "Display" under "Personalization" section.
4. Slide the brightness left and right.

Actual Results:
The brightness of the screen does not adjust as the slider is being moved.

Expected Results:
As the slider moves the brightness of the screen will change.

Repro rate-
3/3 on one device

Comment 1

5 years ago
This seems to happen because:

- The ScreenManager observes the value of the screen.timeout setting and changes the screen's brightness when this value changes
- The value of screen.timeout only changes when the brightness slider is released

I think the settings code needs to be updated to notify observers as the slider is being dragged.
looks like brightness slider is now working with build 20130807051101, can you confirm?
Flags: needinfo?(dwatson)
(Reporter)

Comment 3

5 years ago
The issue still reproduces on build 20130820041204. The brightness is still only being changed once the user lets go of the slider instead of changing while the slider is being moved.

Checked on:
Leo-
Build ID: 20130820041204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bc2c6813842e
Gaia: 849cee8a3ee5a2a6f4e39183549d36c3acc05f2f
Platform Version: 18.1
RIL Version: 01.01.00.019.197 

Unagi-
Build ID: 20130819040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/c8c9bd74cc40
Gaia: f6de05c135913f2cb790759335875bb1b3c4f9bb
Platform Version: 26.0a1

Wanted to see if the latest master had any other results.
Flags: needinfo?(dwatson)
I checked on my unagi with the following builds but could not reproduce it.

Build ID: 20130822041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/74914b454b88
Gaia: a83c5fee49525ec0545059b5a56a3fd9f1c09f19

Build ID: 20130819040203
Gecko: http://hg.mozilla.org/mozilla-central/rev/c8c9bd74cc40
Gaia: b8c30703e2898448c4ccf0032319bba16b1c5173
I also could not reporduce it with one of latests builds (20140905012648).

Comment 6

3 years ago
Actual Results:
The brightness of the screen take effect as the slider when finger left slider.

Expected Results:
As the slider moves the brightness of the screen should immediately take effect when slider move.

could we fix this? many thanks.
blocking-b2g: --- → 2.6+
Priority: -- → P1

Comment 7

3 years ago
scott could you take a look on this issue?
Flags: needinfo?(scwwu)
(Assignee)

Comment 8

3 years ago
Ok I'm on it. Thanks.
Flags: needinfo?(scwwu)
(Assignee)

Updated

3 years ago
Assignee: nobody → scwwu
Created attachment 8701697 [details] [review]
[gaia] scottwu:835497-display-brightness-slider > mozilla-b2g:master
(Assignee)

Comment 10

2 years ago
Comment on attachment 8701697 [details] [review]
[gaia] scottwu:835497-display-brightness-slider > mozilla-b2g:master

Hi Fred, would you be able to review this for me?

I've added a handler that listens to the slider events. In the future we can refactor it with a fxos slider component, but this should work for now.
Attachment #8701697 - Flags: review?(gasolin)

Comment 11

2 years ago
Comment on attachment 8701697 [details] [review]
[gaia] scottwu:835497-display-brightness-slider > mozilla-b2g:master

Looks good with 1 nit, thanks Scott!
Attachment #8701697 - Flags: review?(gasolin) → review+
(Assignee)

Comment 12

2 years ago
Thanks Fred! Merged to master.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.