Closed Bug 835503 Opened 9 years ago Closed 9 years ago

Remove nsCycleCollector::ShouldBeFreed/WasFreed

Categories

(Core :: XPCOM, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla21

People

(Reporter: peterv, Assigned: smaug)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

They add and remove to/from mExpectedGarbage, but nothing ever uses mExpectedGarbage anymore.
Duplicate of this bug: 835505
I guess we have other infrastructure in place to detect windows we expect to be freed not being freed, in the test harness.
Assignee: nobody → bugs
Attached patch patchSplinter Review
Seems to compile on debug build.
Attachment #707299 - Flags: review?(continuation)
Attachment #707299 - Flags: review?(continuation) → review+
I thought I had removed the methods from nsCycleCollector.h too, but maybe not
or the change got lost.
https://hg.mozilla.org/mozilla-central/rev/9f22692e4404
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
No longer depends on: 837131
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.