"Remote Device Error: uninstall failed for org.mozilla.firefox_beta"

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
6 years ago
6 months ago

People

(Reporter: philor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=19208060&tree=Mozilla-Inbound
Android 4.0 Panda mozilla-inbound opt test mochitest-3 on 2013-01-28 12:46:00 PST for push 4f080454a909
slave: panda-0710

========= Started Running verify.py failed (results: 5, elapsed: 13 secs) (at 2013-01-28 12:46:08.536531) =========
python -u /builds/sut_tools/verify.py
 in dir /builds/panda-0710/test/build (timeout 1200 secs)
 watching logfiles {}
 argv: ['python', '-u', '/builds/sut_tools/verify.py']
 environment:
  HOME=/home/cltbld
  PATH=/tools/buildbot-0.8.4-pre-moz2/bin:/usr/local/bin:/usr/local/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cltbld/bin
  PWD=/builds/panda-0710/test/build
  SUT_IP=10.12.135.77
  SUT_NAME=panda-0710
 using PTY: False
01/28/2013 12:46:08: DEBUG: updateSUT: Using device 'panda-0710' found in env variable
01/28/2013 12:46:08: INFO: INFO: Using device 'panda-0710' found in env variable
01/28/2013 12:46:08: DEBUG: calling [nslookup panda-0710]
01/28/2013 12:46:08: DEBUG: calling [ps -U cltbld]
01/28/2013 12:46:08: DEBUG:   PID TTY          TIME CMD
01/28/2013 12:46:08: DEBUG:  5529 ?        00:00:00 python
01/28/2013 12:46:08: DEBUG:  5535 ?        00:00:00 ps
01/28/2013 12:46:08: DEBUG: 11397 ?        00:00:05 twistd
01/28/2013 12:46:08: DEBUG: 18667 ?        00:00:00 twistd
01/28/2013 12:46:08: DEBUG: 20397 ?        00:28:59 screen
01/28/2013 12:46:08: DEBUG: 20398 pts/1    00:00:00 bash
01/28/2013 12:46:08: DEBUG: 21784 ?        00:00:03 twistd
01/28/2013 12:46:08: DEBUG: 22753 ?        00:00:22 python
01/28/2013 12:46:08: DEBUG: 22754 ?        00:01:28 python
01/28/2013 12:46:08: DEBUG: 22763 ?        00:00:15 python
01/28/2013 12:46:08: DEBUG: 22764 ?        00:01:29 python
01/28/2013 12:46:08: DEBUG: 22784 ?        00:00:10 python
01/28/2013 12:46:08: DEBUG: 22785 ?        00:01:26 python
01/28/2013 12:46:08: DEBUG: 22812 ?        00:00:07 python
01/28/2013 12:46:08: DEBUG: 22813 ?        00:01:29 python
01/28/2013 12:46:08: DEBUG: 22826 ?        00:00:07 python
01/28/2013 12:46:08: DEBUG: 22827 ?        00:01:28 python
01/28/2013 12:46:08: DEBUG: 22866 ?        00:00:12 python
01/28/2013 12:46:08: DEBUG: 22867 ?        00:01:28 python
01/28/2013 12:46:08: DEBUG: 22897 ?        00:00:16 python
01/28/2013 12:46:08: DEBUG: 22898 ?        00:01:27 python
01/28/2013 12:46:08: DEBUG: 22908 ?        00:00:31 python
01/28/2013 12:46:08: DEBUG: 22909 ?        00:01:28 python
01/28/2013 12:46:08: DEBUG: 22928 ?        00:00:36 python
01/28/2013 12:46:08: DEBUG: 22929 ?        00:01:28 python
01/28/2013 12:46:08: DEBUG: 22956 ?        00:00:09 python
01/28/2013 12:46:08: DEBUG: 22957 ?        00:01:28 python
01/28/2013 12:46:08: DEBUG: 22987 ?        00:00:00 python
01/28/2013 12:46:08: DEBUG: 22988 ?        00:01:29 python
01/28/2013 12:46:08: DEBUG: 23504 ?        00:00:00 python
01/28/2013 12:46:08: DEBUG: 23505 ?        00:01:28 python
01/28/2013 12:46:08: DEBUG: 24451 ?        00:00:01 twistd
01/28/2013 12:46:08: INFO: INFO: attempting to ping device
01/28/2013 12:46:08: DEBUG: calling [ping -c 5 panda-0710]
01/28/2013 12:46:12: INFO: updateSUT.py: Connecting to: panda-0710
reconnecting socket
01/28/2013 12:46:12: INFO: INFO: attempting to create file /mnt/sdcard/writetest
removing file: /mnt/sdcard/writetest
01/28/2013 12:46:13: INFO: INFO: updateSUT.py: We're running SUTAgentAndroid Version 1.16
01/28/2013 12:46:13: INFO: INFO: Got expected SUTAgent version '1.16'
01/28/2013 12:46:13: INFO: Uninstalling org.mozilla.firefox_beta...
01/28/2013 12:46:14: INFO: Uninstalling org.mozilla.firefox_beta...
01/28/2013 12:46:15: INFO: /builds/panda-0710/error.flg
Remote Device Error: Unable to uninstall org.mozilla.firefox_beta and reboot: Remote Device Error: uninstall failed for org.mozilla.firefox_beta
process killed by signal 15
program finished with exit code -1
elapsedTime=13.716981
========= Finished Running verify.py failed (results: 5, elapsed: 13 secs) (at 2013-01-28 12:46:22.271642) =========

https://tbpl.mozilla.org/php/getParsedLog.php?id=19208058&tree=Mozilla-Inbound
panda-0733

https://tbpl.mozilla.org/php/getParsedLog.php?id=19208253&tree=Mozilla-Inbound
panda-0798
(Reporter)

Comment 1

6 years ago
Looks like what those three at least have in common that the last thing they did before those failures was a try run last Friday.
This was a case of beta pushed to try, as the root cause, however the real puzzling part to me is:

01/28/2013 12:46:13: INFO: INFO: Got expected SUTAgent version '1.16'
01/28/2013 12:46:13: INFO: Uninstalling org.mozilla.firefox_beta...
01/28/2013 12:46:14: INFO: Uninstalling org.mozilla.firefox_beta...

Note the "Uninstalling ..." twice for the same package, now of note is the foopy has the proper [current] cleanup.py:

[cltbld@foopy89 ~]$ ls -l /builds/tools/sut_tools/cleanup.py*
-rwxrwxr-x 1 cltbld cltbld 5661 Jan 18 11:10 /builds/tools/sut_tools/cleanup.py
-rw-rw-r-- 1 cltbld cltbld 4749 Jan 21 15:04 /builds/tools/sut_tools/cleanup.pyc

That .pyc is newer so shouldn't be affecting things bad.

The code, afaict should never get us in a position where its Uninstalling same package name twice -- in a row. And we do print the package name we are working with rather than the generic one we test against.

The for .. in ..: afaict always works in order, none the less this still did 2 attempts on the same package (looking like it succeeded for the first, then failed the second, because it was already gone)

Joel I welcome thoughts. I'm unassigning it from myself for now, and dropping prior since it was a one-off issue.
Assignee: bugspam.Callek → nobody
Severity: blocker → normal
Flags: needinfo?(jmaher)
For reference, that try push was https://tbpl.mozilla.org/?tree=Try&rev=280ad30cd78d
related somehow to android signing or lack thereof?
I don't know how we could have installed something we can't uninstall.
If we did, somehow, these specific devices are probably going to stay broken and will need re-flashing.

If we're trying to uninstall the same product twice, and it succeeded the first time, it won't succeed the 2nd time.  So trying it twice would be the bug in this scenario.
(In reply to Aki Sasaki [:aki] from comment #5)
> I don't know how we could have installed something we can't uninstall.
> If we did, somehow, these specific devices are probably going to stay broken
> and will need re-flashing.

Indeed, and when I looked these devices were happily chugging along with new (green) builds.

> If we're trying to uninstall the same product twice, and it succeeded the
> first time, it won't succeed the 2nd time.  So trying it twice would be the
> bug in this scenario.

This is my idea of *what* was wrong, but *how* its code got it to try to uninstall a second time for the same product, in the same run, is what I don't grok, and why I set needinfo on joel since he touched this cleanup script almost as much as me.
did this only happen once, or have we seen this continually since the original sighting of it?  My thoughts are we might be installing org.mozilla.firefox_beta* which could be multiple packages.  I know we have many processes running.  

We need to verify the package list from "pm list packages" on a failed device and that will give us the information to determine if the device is in a weird state or the code is incorrect.
Flags: needinfo?(jmaher)
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

6 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.