Work - About/Options flyouts intermittently fail to appear when activated

RESOLVED DUPLICATE of bug 817641

Status

Firefox for Metro
Shell
RESOLVED DUPLICATE of bug 817641
5 years ago
3 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work)

(Reporter)

Description

5 years ago
With the patches in bug 835518 applied, I found the following regression.  I suspect it is timing-dependent so I'm not sure if it'll be reproducible on other machines.

Steps to reproduce:
1. Rebuild Metro Firefox by running make in the $OBJDIR/browser/metro directory.
2. Launch Metro Firefox.
3. Click the Settings charm, and choose either "Options" or "About"

Expected results: The selected flyout sidebar appears.

Actual results: Nothing happens until you perform some other user input (e.g. an edge swipe, or choosing one of the settings charm commands again), at which point the sidebar appears.

I logged to make sure the flyoutpanel constructors are called at startup and the "show" method is called at the right time and throws no exceptions.  The code thinks that the sidebar is visible (e.g. getBoundingClientRect returns the correct layout), but it just isn't painted.  I suspect something is wrong with our painting or event handling.

I tried removing the dispatchEvent call in #flyoutpanel.show, and I also tried removing the -moz-transition in flyoupanel.css, but these changes had no effect.

Updated

5 years ago
Summary: On first launch of a new build, flyouts don't appear when shown → Work - On first launch of a new build, flyouts don't appear when shown
Whiteboard: feature=work
Blocks: 807691
Possibly related to bug 807691
I meant to say bug 817641
(Reporter)

Comment 3

5 years ago
By the way, I'm also seeing this intermittently in other situations (i.e. not during the first run of a new build).  It seems to happen more often if a page is loading when I show the flyout.
(Reporter)

Updated

5 years ago
Blocks: 831955
Summary: Work - On first launch of a new build, flyouts don't appear when shown → Work - About/Options flyouts intermittently fail to appear when activated
Is this still happening for you?
(Reporter)

Comment 5

5 years ago
Yes, still seeing this intermittently.
(Reporter)

Comment 6

5 years ago
By the way, I still see this most often first thing after starting a new build; closing and re-launching the browser generally makes it go away.
Blocks: 817641
No longer blocks: 817641
Depends on: 817641
I could never reproduce this but I think it is fixed by bug 817641.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 817641
(Assignee)

Updated

3 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.