[B2G] [Hardware] Airplane mode off does not automatically turn off using Long Press

RESOLVED WORKSFORME

Status

Firefox OS
Hardware
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: amiller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build ID: 20130125070201
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18/rev/94a2d6fcdfde
Gaia:   6369dbf33b622faf4b4d176fed30b77c5c319dfc
Kernal: December 5th
MISDN: 6509336963
IMEI: 864899012585998
Date and Time: 1/28/2013  4:40 PM PST
Device: Unagi

Description: Airplane mode off does not automatically turn off. You must go into settings and Select WiFi and turn it on manually for the web browsing to occur. 

Re-pro Steps:

1. Go to settings
2. Make sure that you are connected to Wi-Fi
3. Navigate to the homescreen and long-press on the power button. 
4. Turn the Airplane mode on 
5. Go to the website browser on the device and try to connect to a web page
6. Device message " Turn on internet connection" displays when you try to go to a website
7. Go back to the home screen and long-press the power button and turn the Airplane mode back off.

Expected Result: When you log onto a website it will automatically turn the Wifi or data connection back on so that you can browse the web.  

Actual Result:

Turning the Airplane Mode back off does not automatically turn the Wifi connection back on.

Comments: I had to manually go into Wifi settings and turn the Wifi connection to on to access web browsing. 

Repro Rate: 4/4
Cleaning up this component. Just tested this on my hamachi with gaia 62d09fb5fb595c63356e493c192d878fa7128cdc and gecko 02cebc7fa1460b3991a9724c6bcb0f735a698ffb and I can't reproduce the problem. Turning off the airplane mode turns the WiFi back on as expected.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.