difference between pvt build and releases.mozilla.org nightly

RESOLVED INCOMPLETE

Status

Firefox OS
GonkIntegration
RESOLVED INCOMPLETE
5 years ago
5 years ago

People

(Reporter: onecyrenus, Assigned: cmtalbert)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Unsure if this is based upon changing infrastructure or not, but I am executing the following. 

Download releases.mozilla.org/b2g/ <-- grabbing the nightly
01/25/13

Flash device. 

Open the music app, and attempt to play music, decrease the volume. The volume does not decrease. 

Download pvtbuilds.mozilla.org/
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi/2013/01/2013-01-25-23-02-01/

Flash device

Open the music app, and attempt to play music, decrease the volume. The volume does decrease. 

Download eng pvtbuild
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/mozilla-b2g18-unagi-eng/2013/01/2013-01-25-23-02-01/

Flash Device

Open the music app, and attempt to play music, decrease the volume. The volume does decrease. 

My question here is whether the variance in build is expected.  Are both of these builds to be used for test.
Those are completely different sets of automation that are running.

releases.mozilla.org/b2g/ is the old A-Team based automation.  I don't know if it is expected to be working or not.

pvtbuilds.mozilla.org is the new automation maintained by Release Engineering.  This is the future and where you should be grabbing your builds from.

If the type of build you're looking for is available on pvtbuilds, please use those copies.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Assignee: nobody → ctalbert
(Reporter)

Comment 2

5 years ago
John, the issue is not closed as the builds are still out there and it is unclear if other people may be using them.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
There are large differences between the two builds.  The most significant is that the build at releases.m.c/b2g uses the latest of all the B2G repos (i.e., it does a config.sh).  The rel-eng pvtbuilds only have up-to-date gecko and gaia; other repos need to be manually updated on-demand.

No doubt this leads to different behavior at times.  I've been concerned about this, but am not sure what best to do about it.  We should probably open this discussion to a wider audience (b2g-internal?).
(Assignee)

Comment 4

5 years ago
This does need wider discussion and we should decide if we care about keeping the full builds going and uploading to releases.* Let's take this to a mailing list. I think the real question here is:
1. Is it worthwhile to keep around "latest of everything" builds for our platforms or are the snapshots of the repos good enough to work from?

And then we have options:
2a. If we decide to turn off the "latest of everything" then we should disband the automation generating those builds.
2b. If we decide to keep both around going forward we should put some kind of manifest in each location so that people know what they are getting when they grab one of those builds.
(In reply to Clint Talbert ( :ctalbert ) from comment #4)
> This does need wider discussion and we should decide if we care about
> keeping the full builds going and uploading to releases.* Let's take this to
> a mailing list.

Good idea; I'll start a thread in b2g-internal.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.