[Homescreen] Possible to display blank grid page by panning very fast

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Homescreen
--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: benfrancis, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Reporter)

Description

5 years ago
Originally reported on Leo, but also reproducible on Unagi.

STR:
* Pan left and right on homescreen quickly.

Sorry, that's the best I can do. This is quite hard to reproduce during normal use.

Video to follow.
(Reporter)

Comment 1

5 years ago
Please see video at http://www.youtube.com/watch?v=3Ozmvekxp_M
(Assignee)

Comment 2

5 years ago
Maybe it is the same problem that I found here #827130
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 3

5 years ago
I am sure that is the same problem, sometimes the previous page is not re-painted when we change the display value from 'none' to 'block'
(Assignee)

Updated

5 years ago
blocking-b2g: --- → tef?
(Assignee)

Comment 4

5 years ago
Follow up https://bugzilla.mozilla.org/show_bug.cgi?id=827130
We discussed this during triage today and since it appears the screen will appear once panning has finished, we can't block on this.
blocking-b2g: tef? → -
Duplicate of this bug: 836796
I /think/ this happens when the finger actually exits the touch area on the left and/or right for a brief moment and this confuses the homescreen.    I can't seem to dup this when being mindof of keeping my finger within the bounds of the surface.
Blocks: 837218
Severity: normal → major
Pre-emptively CCing graphics people since this may be a Gecko issue.
(In reply to Michael Vines [:m1] [:evilmachines] from comment #7)
> I /think/ this happens when the finger actually exits the touch area on the
> left and/or right for a brief moment and this confuses the homescreen.    I
> can't seem to dup this when being mindof of keeping my finger within the
> bounds of the surface.

My experience is the same as michael's here. To me it doesn't have to do with the speed of the swipe, but with going out of bounds. Or maybe starting out of bounds. I don't know if gecko ever delivers touchcancel events. But if it does, perhaps the panning code needs to listen for it and treat touchcancel the same as touchend.  That's completely a guess, however.
(Assignee)

Comment 10

5 years ago
My experience is different. All these problems are not reproducible in desktop. Sometimes, when a page is translated offscreen although it defines display as block, then it won't be re-painted and we can see blank pages.
Adding Timothy, who was looking at bug 827130.
(Assignee)

Comment 12

5 years ago
Could you test this patch [1]? I guess that resolves this problem as well

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=827130#c28
(Assignee)

Comment 13

5 years ago
Sorry, applying these two patches this bug is not reproducible:

https://bugzilla.mozilla.org/show_bug.cgi?id=842218#c12
https://bugzilla.mozilla.org/show_bug.cgi?id=827130#c28
(Assignee)

Comment 14

5 years ago
I cannot reproduce it after landing bug 842218, can you still reproduce the problem? thanks a lot for your help Ben
Flags: needinfo?(bfrancis)
(Assignee)

Comment 15

5 years ago
I cannot reproduce so closing, please re-open if you can reproduce the problem
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(bfrancis)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.