Blocklist some Bandoo add-on or other.

RESOLVED DUPLICATE of bug 812456

Status

()

Toolkit
Blocklisting
RESOLVED DUPLICATE of bug 812456
5 years ago
2 years ago

People

(Reporter: kmag, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Not sure which add-on is responsible for this, but bandoo.com's installer installs 3 add-ons (they don't bypass about:newaddon). At some point the default search engine, about:newtab, homepage, and keyword URL are changed. Disabling DataMgr fixes the first three, not the keyword uRL, which still points to:

http://www1.search-results.com/web?l=dis&q=foo+bar&o=APN10644&apn_dtid=^BND101^YY^US&shad=s_0047&apn_uid=5125720904634885&gct=ds&apn_ptnrs=AG5&lang=en&atb=sysid%3D101%3Aappid%3D0%3Auid%3D30991b2418fc98df%3Auc%3D1359435041%3Asrc%3Dffb%3Ao%3DAPN10644

DataMgr: {1FD91A9C-410C-4090-BBCC-55D3450EF433} ~6M users (arguably also a deceptive name)
Bandoo: ffox@bandoo.com ~340K users
Search-Results Toolbar: {dd6b651f-dfb9-4142-b0bd-09912ad22674} ~24K users.

The fact that DataMgr, which does nothing that any user could possibly want, and gives them search engines and homepage that no-one in their right mind would use given the choice, has so many users while the other two add-ons (which some 11 year olds could possibly find mildly amusing) do not is highly suspicious to me.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 812456
I don't think this is a duplicate. That block request was for crashes, this is for policy violations, and includes two other add-ons.
The original bug also mentions Bandoo and others, and explains that we don't fully understand the impact of blocking DataMngr, and we're working with Bandoo on addressing the crashing issues.

I'm CC'ing akeybl and bajaj, who can forward the info on this bug to the right people.
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.