pdf.js: Links within some PDFs does not work even if I click them.

RESOLVED DUPLICATE of bug 793804

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 793804
6 years ago
6 years ago

People

(Reporter: rshimazu, Unassigned)

Tracking

19 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130116072953

Steps to reproduce:

Please access to the following urls, and click the texts which start with "http://".

http://blog.summerwind.jp/download/jssm/slide.pdf#page=2
http://www.tsukaeru.net/lp/fx/TN_A4_FX_guide_ftl_110311.pdf#page=3
http://www.es.emb-japan.go.jp/download/Presentacion_400_JAPANESE.pdf
http://www.jpeds.or.jp/saisin/saisin_1101182.pdf#page=2




Actual results:

Nothing happens. No click event at all.


Expected results:

Links should work as Internet Explorer with Adobe Reader handles them as expected.

Comment 1

6 years ago
It’s not a link in PDF.js, Okular, Evince.  Probably duplicate of bug 793804.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Ever confirmed: true
Whiteboard: DUPEME?

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME?
Duplicate of bug: 793804
(Reporter)

Comment 3

6 years ago
I do not think this is duplicate of bug 793804.
The urls in sample PDFs which I showed in #c0 are recognized as the links by Adobe Reader on IE. And I am not 100% sure if all those PDFs are made from MS WORD.
(Reporter)

Comment 4

6 years ago
And the urls in sample PDFs which I showed are recognized as the links by Chrome PDF Viewer on Google Chrome.
Although those PDFs are not made by Microsoft Word, it's common that they don't contain the URL annotation for those URLs. Perhaps Adobe Reader and Chrome PDF Viewer are converting a mere text string to a link if it looks like a URL.
TextLink add-on worked because PDF.js converts a PDF to an HTML.
https://addons.mozilla.org/ja/firefox/addon/text-link/
You need to log in before you can comment on or make changes to this bug.