All users were logged out of Bugzilla on October 13th, 2018

buildstep that TinderboxPrints the mozharness_revlink makes tbpl ugly and stupid-looking

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: philor, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Back in September in bug 791029, tbpl stopped insisting that only TinderboxPrints which are at the start of a line count as TinderboxPrints.

That made TinderboxPrint something like Beetlejuice, not a word you want to casually toss around.

The buildstep in b2g builds which outputs the mozharness_revlink doesn't fear saying it:

========= Started 'echo TinderboxPrint: ...' (results: 0, elapsed: 0 secs) (at 2013-01-28 20:31:27.515588) =========
echo TinderboxPrint: mozharness_revlink http://hg.mozilla.org/build/mozharness/rev/f7ba3a5cffee
...
 argv: ['echo', 'TinderboxPrint:', 'mozharness_revlink', 'http://hg.mozilla.org/build/mozharness/rev/f7ba3a5cffee']
...
TinderboxPrint: mozharness_revlink http://hg.mozilla.org/build/mozharness/rev/f7ba3a5cffee
...
========= Finished 'echo TinderboxPrint: ...' (results: 0, elapsed: 0 secs) (at 2013-01-28 20:31:27.623114) =========

Which results in b2g builds having six line items in the unordered list in the bottom right: the gaia_revlink which we only get because of bug 791029, since it's a mozharness style one with a time and an INFO in front of it, and five lines of the mozharness_revlink in varying degrees of readability, including "...' (results: 0, elapsed: 0 secs) (at 2013-01-28 20:31: 27.515588) ========="
Regression From Bug 829145
Depends on: 829145
So as an ugly workaround in buildbot you can do something like:

$ python -c "print 'Tinder' 'Box' 'Print:'"

instead of 'echo' for this, python auto-concats all adjacent strings together.

and you might get around the ========= Finished 'echo TinderboxPrint: ...'   stuff by just adding a description= to the step. (that doesn't use the TinderboxPrint phrase).
(Assignee)

Updated

6 years ago
Assignee: nobody → armenzg
(Assignee)

Comment 4

6 years ago
Created attachment 707636 [details] [diff] [review]
Use OutputStep instead
Attachment #707636 - Flags: review?(aki)
(Assignee)

Updated

6 years ago
Priority: -- → P1

Updated

6 years ago
Attachment #707636 - Flags: review?(aki) → review+
(Assignee)

Comment 5

6 years ago
Comment on attachment 707636 [details] [diff] [review]
Use OutputStep instead

0f3e640208d0
Attachment #707636 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Whiteboard: waiting on reconfig

Comment 6

6 years ago
This is in production.
(Assignee)

Comment 7

6 years ago
It looks like this now:
* mozharness_revlink: http: //hg.mozilla.org/build/mozharness/rev/ce8901b71fed
* gaia_revlink: http: //hg.mozilla.org/integration/gaia-nightly/rev/ff42ce81a69c

I have not yet understood why tbpl add that space after "http:".
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: waiting on reconfig
Product: mozilla.org → Release Engineering
Component: General Automation → Mozharness
You need to log in before you can comment on or make changes to this bug.