[Building Blocks][Lists] Content should be centered in the container box

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Sergi, Assigned: arnau)

Tracking

unspecified
x86
Mac OS X
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 verified)

Details

(Whiteboard: visual design [UX-P1], TEF_REQ)

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 707526 [details]
Content Centering :: Screenshot

List elements containing one single text line are not correctly aligned. They are aligned like they were supposed to have 2 lines, and that makes the composition look visually weird.

The content displayed in a list element should have to be always centered in the box containing it.
Assignee: nobody → arnau

Comment 1

5 years ago
Created attachment 717102 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8270

Pointer to Github pull-request
Comment on attachment 717102 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8270

I took this bug because initially looked like a css thing, but I asked Alberto for help, as I needed to remove an item in the js file.
And lists Building Block did the rest ;)
Arnau
Attachment #717102 - Flags: review?(francisco.jordano)
Attachment #717102 - Flags: review?(francisco.jordano) → review+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Component: General → Gaia
Comment on attachment 717102 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8270

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
String or UUID changes made by this patch:
Attachment #717102 - Flags: approval-gaia-v1?
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: not matching UX specs
Testing completed: Yes
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch:
Additional comments for triage:
This bug was caused because contact's list always had two lines, one for name and a second one for social info. This second line was always rendered with empty tags (<p></p>) even if it had no info.
We have removed them to allow css centering.
Comment on attachment 717102 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8270

Approved for v1-train
Attachment #717102 - Flags: approval-gaia-v1? → approval-gaia-v1+
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
Uplifted commit 7a411f43bc664a7132ce36a2150d2407cb49226e as:
v1-train: 6d4edead11c0717e6370acba93d2b8c430f07a70
status-b2g18: affected → fixed
Safe change, required for uplifting cleanly bug 835743.
blocking-b2g: --- → tef+
status-b2g18-v1.0.1: wontfix → affected
(In reply to Daniel Coloma:dcoloma from comment #8)
> Safe change, required for uplifting cleanly bug 835743.

bug 846708 I meant
v1.0.1: c52be3f4d35f6819b55fd4aadd2258af7d52879a
status-b2g18-v1.0.1: affected → fixed
Can you please provide steps to verify this fix - as we will blackbox test from the UI?
As you can see in the attached screenshot, appears outlined in red the incorrect behaviour previous to this patch: when we had only one line of text in a row, the content was not centered but top aligned.
This patch removes empty <p><p> (the second line of text) allowing content to be centered in the row.
Created attachment 730243 [details]
Content Centering image 1
Created attachment 730244 [details]
Content Centering image 2
Unagi Build: 20130322070202
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/5aacf880400b
Gaia   5a31a56b96a8fc559232d35dabf20411b9c2ca1d
Kernel: Dec 5th

In the two screenshots I just added, you can see that Contacts is now fixed however Facebook still has the center justifying not working properly. This was checked on V1.0.1 and V1.

Updated

5 years ago
Flags: in-moztrap-
Unagi Build: 20130401070203
Gecko:  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/b28463f2e718
Gaia:   ddb38ac8a34f9e30e09d0ff3b5c1bfb9b664b7c3
Kernel: Dec 5th

Unagi Build: 20130401070203
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f9f11b8cbf8a
Gaia   663101b6eb809383e5882d9bc3868a923a57998a
Kernel: Dec 5th

Just wanted to give updated build information so it was provided because i forgot to post the V1.0.1 info last time.
Ok I was mistaken.....I thought due to the screenshots that both the Contacts and Facebook lists were being called out here which both had the same issue it appeared at one time. Now that Contacts is fixed I will mark as verified and shut this one down.
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.