Closed Bug 835779 Opened 10 years ago Closed 2 years ago

ctrl+backspace in URL bar skips last "word" in some cases

Categories

(Firefox :: Address Bar, defect, P3)

21 Branch
x86_64
Windows 7
defect

Tracking

()

RESOLVED DUPLICATE of bug 1559083

People

(Reporter: brunis, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130128 Firefox/21.0
Build ID: 20130128030943

Steps to reproduce:

1. put cursor at the end of the url in url bar
2. press ctrl+backspace a couple of times




Actual results:

in some cases it skips the last word on the first press.

eg. (my "|" inserted to indicate cursor placement)
http://some-company.com/default.aspx?var=value400|
becomes
http://some-company.com/default.aspx?|value400



Expected results:

it should have just deleted the first word, leaving this url:
http://some-company.com/default.aspx?var=
Works for me with 2013-01-29-03-08-51-mozilla-central-firefox-21.0a1.en-US.linux-x86_64 with the example.  Does it happen in other text fields?
it's a bit flaky, mostly happens with the suggestion list open and an item highlighted.

right now it's actually highlighting the last word instead of deleting it.
It seems to work flawlessly in the "Home page" input under options > general.

And the same with the search bar, even though long complex url's popup (suggestions) it always works removing the last word.

So it's just the url bar.
Component: Untriaged → Location Bar
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:21.0) Gecko/20130204 Firefox/21.0
Build ID: 20130204030941

I confirm this issue in the latest Nightly (04.02.2013), Firefox 19 beta 4 and latest Aurora.
Screencast that demonstrate this behavior: http://www.screencast.com/users/AlexandraLucinet/folders/Default/media/cd68a42e-a612-464f-8150-527f7052df46

If I press ctrl+backspace after selecting from the suggestion list, the last item is highlighted ("com"). When I double press ctrl+backspace, the word "google" is deleted, not "com" as expected. If I set browser.urlbar.autoFill to false the problem is gone.

Here is the range that I found:
Last good nightly: 2012-03-13
First bad nightly: 2012-03-14
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1ca7a94573f2&tochange=c71845b3b2a6
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
(In reply to Alexandra Lucinet [QA] from comment #4)
> Here is the range that I found:
> Last good nightly: 2012-03-13
> First bad nightly: 2012-03-14

This is just when we enabled inline autocomplete and likely happens when inline adds completion to the search

Bug 719888 *could* improve this.
Depends on: 719888
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
See Also: → 1559083

sorry, didn't mean to solve this. Bug 1559083 is similar or maybe the same, it has good str.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Status: NEW → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1559083
See Also: 1559083
You need to log in before you can comment on or make changes to this bug.