All users were logged out of Bugzilla on October 13th, 2018

[e.me] scrolling through the history ends up panning to the home screen than scrolling all the history

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: nhirata, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/b30d5224b47b
Mercurial-Information: <project name="integration/gaia-1_0_0" path="gaia" remote="hgmozillaorg" revision="2a3396c64c0a"/> 
BuildID 20130128070201
Version 18.0
Unagi
  
## Repro :
1. swipe to e.me
2. search for a bunch of things
3. click in the search field
4. try to scroll in the history to get to the clear history

## Expected :
you can scroll through the history to the end

## Actual :
it partially scrolls, and then you end up swiping to the home screen.
Broken functionality... and you can't clear the history when this happens.
We discussed this during triage and while it is indeed annoying, it doesn't feel like something we'd hold the release for.
blocking-b2g: tef? → -
blocking-kilimanjaro: ? → ---
tracking-b2g18: ? → ---
tracking-b2g18: --- → +
(Assignee)

Updated

6 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 3

6 years ago
Created attachment 709706 [details]
Patch v1

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: history button broken 
Testing completed: yes
Risk to taking this patch (and alternatives if risky): close to null
Attachment #709706 - Flags: review?(ran)
Attachment #709706 - Flags: approval-gaia-v1?
Attachment #709706 - Flags: review?(ran) → review+
(Assignee)

Comment 4

6 years ago
https://github.com/mozilla-b2g/gaia/commit/1339da5e415db5f31f73d067d0475048864df9d7
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
status-b2g18: --- → affected
Comment on attachment 709706 [details]
Patch v1

Approving for v1-train uplift.
Attachment #709706 - Flags: approval-gaia-v1? → approval-gaia-v1+
v1-train: 2ed05a450ddaa2ea6f9b823db9c436c1509f1d2c
status-b2g18: affected → fixed
Batch edit: bugs fixed on b2g18 since 1/25 branch of v1.0 are fixed on v1.0.1
status-b2g18-v1.0.1: --- → fixed
You need to log in before you can comment on or make changes to this bug.