Closed Bug 83599 Opened 20 years ago Closed 20 years ago

[RFE] Manage Bookmark window should sort folders first, then bookmarks; ignore parent items

Categories

(SeaMonkey :: Bookmarks & History, enhancement)

x86
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 64272

People

(Reporter: bugs, Assigned: bugs)

Details

I just recently tried to sort through my large bookmark list, trying to organize
it through this build's Manage Bookmark list.  I hit "Sort by name", and every
item in the window gets sorted!!!  I thought it would sort any open folder, and
not any parents.

Suggested changes to the sorting algorythm:
1.  Only sort the currently expanded folder being viewed, ignoring any parents.
 If there's any expanded folders, only work on them.
2.  Sort directories first, placing them on top, before any individual bookmarks.
3.  Give the user the option to use older sorting method.

Also, isn't there a "flatten" option, which would peramently sort the bookmarks,
instead of having Mozilla have to remember the sort the folder automatically?
Duplicate of Bug 64272? 
ys basically, although the suggestions differ mildly

*** This bug has been marked as a duplicate of 64272 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** Bug 150746 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.