[Settings][Crash Reporting] Ask me when a crash occurs does not fit in the settings display.

VERIFIED FIXED

Status

Firefox OS
Gaia::Settings
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: kaze)

Tracking

({late-l10n})

unspecified
ARM
Gonk (Firefox OS)
late-l10n

Firefox Tracking Flags

(b2g18 fixed)

Details

(Whiteboard: polish)

Attachments

(5 attachments)

Created attachment 707788 [details]
screenshot

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/b9871d06ba06
Gaia   03401aa0cedac9bc8332e1342aac274a62f4416f
BuildID 20130129070201
Version 18.0
Unagi
  
## Repro :
1. go to settings -> Improve Firefox OS
2. scroll down

## Expected :
selections should be readable.

## Actual :
1. in portrait mode, Ask me when a crash occurs does not fit.

## Note :

Comment 1

5 years ago
need UX confirm to give a shorter string or other solution
Flags: needinfo?(lco)

Comment 2

5 years ago
How about "Ask each time" ?
Flags: needinfo?(lco)

Updated

5 years ago
Assignee: nobody → gasolin

Comment 3

5 years ago
Created attachment 716924 [details]
Change i10n wording to 'Ask each time'
Attachment #716924 - Flags: review?(ehung)

Comment 4

5 years ago
Comment on attachment 716924 [details]
Change i10n wording to 'Ask each time'

r=me, only l10n changes here.
Attachment #716924 - Flags: review?(ehung) → review+

Updated

5 years ago
Keywords: late-l10n

Comment 5

5 years ago
https://github.com/mozilla-b2g/gaia/commit/91d3454282880f6e20ab64ea3ceab475be2296f4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 829468
(Assignee)

Comment 7

5 years ago
Comment on attachment 716924 [details]
Change i10n wording to 'Ask each time'

This bug has been recently reported again, see bug 829468. Can we uplift this string change to v1-train? v1.0.1?

[Approval Request Comment]
Bug caused by (feature/regressing bug #): ?
User impact if declined: poor UX, truncated string
Testing completed: manual
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch:
Attachment #716924 - Flags: approval-gaia-v1?(21)

Comment 8

5 years ago
Axel - is this string change kosher?
Flags: needinfo?(l10n)

Comment 9

5 years ago
This change doesn't adjust the ID, so localizers won't be noticed. That'd be a No, neither ok for v1-train nor for master, actually.

Reopening.
Status: RESOLVED → REOPENED
Flags: needinfo?(l10n)
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Attachment #716924 - Flags: approval-gaia-v1?(21)
(Assignee)

Comment 10

5 years ago
Created attachment 749844 [details]
link to pull request

https://github.com/mozilla-b2g/gaia/pull/9790

As this issue has been reported in bug 829468, and because it’s specific to the non-master branches, I think it should be uplifted to v1-train and possibly to v1.0.1 as well. Pike, would that be OK with you?
Assignee: gasolin → kaze
Attachment #749844 - Flags: review?(l10n)
Attachment #749844 - Flags: approval-gaia-v1?(21)

Comment 11

5 years ago
Comment on attachment 749844 [details]
link to pull request

r=me for master and v1-train, but this shouldn't go on 1.0.1, I think.
Attachment #749844 - Flags: review?(l10n) → review+
(Assignee)

Comment 12

5 years ago
Thanks for the quick review! Merged on master:
https://github.com/mozilla-b2g/gaia/commit/0e5ed0a34e80c4087a6219ea84883fe7d6cd8f59

Waiting for Vivien’s feedback before merging to v1-train.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Comment on attachment 749844 [details]
link to pull request

v1-train sounds good. thanks.
Attachment #749844 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+

Comment 14

5 years ago
Hi, all,

Thanks for your help on this case.
I verified this case on Mozilla-central(master).
After we merged it to vi-train, I will attach the other screenshot.

* Test build:(Mozilla-central-20130516031119)
  + Mercurial-Information:
   - Gecko revision="c7df35aa72e1"
   - Gaia revision=""
  + Git-information
   - Gecko revision="5541c2365f25696f084e46a71de3777a7b0efe8e"
   - Gaia revision="e99e62ce2586c98ae491cccc9fe772f8cddf423b"

Thanks!

Comment 15

5 years ago
Created attachment 750915 [details]
UI truncation
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 0e5ed0a34e80c4087a6219ea84883fe7d6cd8f59
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(kaze)
status-b2g18: --- → fixed

Comment 18

5 years ago
Verified on V1-Train.
The UI shows the correct wording as we expected.
Attaching the screenshot.

 * Test build:(Mozilla-b2g18-unagi-eng/20130531230204)
   + Mercurial-Information
     - Gecko revision="36c6632443fb"
     - Gaia revision=""
   + Git
     - Gecko revision="fe01a25875349894a3e26d288e979dba22d4a7db"
     - Gaia revision="cac79d6e0f804af9a1203f45ca6b8eff13f1cf3e"
Status: RESOLVED → VERIFIED

Comment 19

5 years ago
Created attachment 757798 [details]
New wording of improve Firefox OS page
You need to log in before you can comment on or make changes to this bug.