Separate window disappears to the background

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: Marvin Fröhlich, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Open a second or third (etc.) Firefox window. I use CTRL+N to do that. Begin to type the url of a website like imdb, youtube, or something. Use the arrow keys to select one of the completion suggestions and hit enter to move on to the page.


Actual results:

When Firefox attempted to load the page the current window is moved to the background bringing one of the other Firefox windows to the foreground. It looks like you surfed to one of the other pages, you visited today. You have to hit ALT+TAB or use the mouse to bring the correct window up front.

This doesn't always happen, but is quite reproducible. After it happened once it won't ever happen again, if you try to provoke it right after that.


Expected results:

The current window should stay in the foreground.
Created attachment 710111 [details]
Switch to tab
Marvin, if you already have a window with "imdb.com" opened and you want to open a new window with "imdb.com", the first suggestion will be to "switch to tab". If you hit that suggestion it will bring you to that opened window from the background. (See attachement).

If this not solves the issue and it still persists, please try reproducing: 
- in safe mode http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
- with a new profile http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

and report back.
(Reporter)

Comment 3

5 years ago
I see, what you mean. But that's not my situation. I have a window with an arbitrary site open. Then I hit CTRL+N to open a new window and type "im". The first suggestion is "http://www.imdb.de/". And if I select that and press enter, the site is requested and on arrival of the response the window flips into the background.

I have checked your guess. And I didn't know that feature of "Switch Tab", since I always open a new window for a new browse topic. If I stay on imdb or youtube, I stick to the same window. But if I want to do a new google search, I open a new window and star the search there. The same for a youtube search or imdb or what ever.
Marvin, can you check if this still happens in safe mode, and with a new profile? I'm trying to reproduce the issue and can't.  Thanks!
Flags: needinfo?(marvin.froehlich)
(Reporter)

Comment 5

5 years ago
Are you talking about "Private Browsing" when you say "Save mode"? I can try that. Though it doesn't happen always. It just happens very often. I just checked it in private browsing mode. But it didn't happen on first try. I will try a new profile soon.

I do know, that this happens on a colleague's firefox, too.
Flags: needinfo?(marvin.froehlich)
Marvin -- I meant to start Firefox with all the extensions disabled, as described here: http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode   or in German, https://support.mozilla.org/de/kb/Abgesicherter-Modus  

This helps us to find out if it is a problem in Firefox, or a problem in an extension.
Flags: needinfo?(marvin.froehlich)
(Reporter)

Comment 7

5 years ago
I was just able to reproduce the bug in Safe mode.

I restarted it in safe mode and browsed to my daily sites. Then I left it alone for 10 minutes to take care of some house work. Then I hit CTRL+N, typed "you" and selected the first suggestion, which was youtube and saw the window flipping to the background.
Flags: needinfo?(marvin.froehlich)
This sounds similar to bug 790013 to me. You could try confirming this by following the "Last resort" steps (disabling protected mode) at http://forums.adobe.com/message/4468493 and seeing if they resolve the problem.
(Reporter)

Comment 9

5 years ago
Yes, this sounds like a very similar issue probably caused by the same bug.

I have disabled protected mode in flash player and will report back, if the problem persists.
> will report back, if the problem persists.

closed -> reporter don't update it, so it looks OK now
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.