Re-enable @enforce_sequence decorator on reset PIN views

RESOLVED FIXED in 2013-02-14

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: kumar, Assigned: wraithan)

Tracking

2013-02-14
x86
Mac OS X
Points:
---
Dependency tree / graph

Details

(Whiteboard: p=2 [qa-])

The @enforce_sequence decorator is necessary to prevent a user from getting stuck on a view that depends on an initialized user state.

However, it was causing problems for the reset flow (bug 822491) so it is temporarily disabled. This is to re-enable the decorator and unskip tests.
Assignee: nobody → xwraithanx
Blocks: 775802
Priority: -- → P2
Duplicate of this bug: 836047
Blocks: 836089
Target Milestone: --- → 2013-02-14
Version: 1.0 → 1.1
Whiteboard: p=2
https://github.com/mozilla/webpay/pull/54/files

Needs review, people are offline.
https://github.com/mozilla/webpay/commit/a55a2edae8305f982e5102d3b3c8bd772f42cc0c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Unskip the related tests: https://github.com/mozilla/webpay/commit/86fa083adf192cbbe500a2e84d5f33f1672e2bc3

Comment 5

4 years ago
Can you please add some STRs or mark it as [qa-] ?
Whiteboard: p=2 → p=2 [qa-]
You need to log in before you can comment on or make changes to this bug.