[Crash Reporting] Report gets sent automatically regardless of privacy setting for OS Crashes

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: nhirata, Assigned: hub)

Tracking

(Blocks: 1 bug, {regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g18+, b2g18-v1.0.0 unaffected)

Details

(Whiteboard: c= s=2013.06.14 ,)

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/b9871d06ba06
Gaia   03401aa0cedac9bc8332e1342aac274a62f4416f
BuildID 20130129070201
Version 18.0
Unagi
  
## Repro :
1. flash device
2. do not select "I want to help improve Firefox OS " when going through FTE
3. go to settings -> Improve Firefox OS
4. verify that "Ask me when a crash occurs" is selected
5. kill -11 b2g process.
6. go into the /data/b2g/mozilla/Crash Reports folder

## Expected :
Pending folder will have the report after reboot

## Actual :
the crash is in the submitted folder, you can verify that the crash has been submitted using Socorro's interface and searching the ID

## Note :
1. Also there's a small banner that appears that says Firefox crashed with a "Report" box that's clickable.  But it only lasts a short time.  Probably need to file a bug about that...
This violates privacy if we auto send regardless....
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?
Blocks: 833574
Turns out that even if you select don't send; it still sends...
Summary: [Crash Reporting] Report gets sent even though "Ask me when a crash occurs is set" for a OS Crash → [Crash Reporting] Report gets sent automatically regardless of privacy setting for OS Crashes
Interesting. I remember testing this earlier and I believe it worked and was honoring the settings.
Assignee: nobody → hub
blocking-b2g: tef? → tef+
tracking-b2g18: ? → ---
Keywords: regression
(Assignee)

Comment 4

5 years ago
I'll have a look at it.
Hub et all,

To note : I was testing on mozilla-b2g18-unagi which I believe is master?  I had mistakenly pulled the wrong build.  It's still a regression.

Instead of b2g18 v1.0.0  I think that might be the difference... so something broke between the 2 branches.

It works fine on the b2g18 v1.0.0 branch on today's build.
Marking status-b2g18 and status-b2g18-v1.0.0 as affected, please update the status to fixed once this is verified landed on v1-train/mozilla-b2g18 and v1.0.0/mozilla-b2g18_v_1_0_0
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → affected
(Assignee)

Comment 7

5 years ago
I haven't been able to reproduce the problem at all. I build the v1-train (1.0.1.0-prerelease)

I definitely have the crash reports in "pending"
If this can't be reproduced, then there's no need to block here but please renominate if there are crash reports sent without explicit approval.
blocking-b2g: tef+ → -
tracking-b2g18: --- → +
Naoki are you ok with closing WFM?
Batch edit: Bugs marked status-b2g18: affected after 2/13 branching of v1.0.1 are now also status-b2g18-v1.0.1: affected
status-b2g18-v1.0.1: --- → affected
(Assignee)

Comment 11

5 years ago
The problem is that the report gets stored on the device and then when we enable sending crash report they'll be sent.

I do believe that if we decided to not send the crash report because the user disabled it, we should actually delete the crash report.

Naoki, what do you think?
Flags: needinfo?(nhirata.bugzilla)

Comment 12

5 years ago
(In reply to Hubert Figuiere [:hub] from comment #11)
> I do believe that if we decided to not send the crash report because the
> user disabled it, we should actually delete the crash report.

That sounds good to me.
Sorry, didn't realized I was pinged in this bug more than once.  David, next time can you needinfo me please?  Thanks for needinfoing me Hub.

It's a tough call, Hub.  I think that may warrant a bug on it's own.

Personally for troubleshooting purposes, it may be best to leave crashes on the device.  Ie if they complain that it crashes too much, we can have tech support walk them through and send the reports.  Having said that, I see the concern for freeing up the space on a mobile phone.  This is why I think it might warrant a bug on it's own to have a discussion around it.
Flags: needinfo?(nhirata.bugzilla)

Comment 14

5 years ago
Adding c= and p= whiteboard tags to get this into the scrumbugs backlog.
Status: NEW → ASSIGNED
Whiteboard: c=performance p=8

Comment 15

5 years ago
Oops. Didn't mean to set p= on this.
Whiteboard: c=performance p=8 → c=performance
WFM on leo : 
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/765d296cff66
Gaia   e420d71c9528786621f176fb4ce67d291e0a530e
BuildID 20130501070205
Version 18.0

WFM on buri:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/010498e599a7
Gaia   09046df332cd217cf4fad55c48ce9ce3f14ee5a4
BuildID 20130501070201
Version 18.0

1.0.0 had worked fine, see comment 5.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-b2g18: affected → ?
status-b2g18-v1.0.0: affected → unaffected
status-b2g18-v1.0.1: affected → ?
Resolution: --- → WORKSFORME

Updated

5 years ago
status-b2g18: ? → ---
status-b2g18-v1.0.1: ? → ---
(Assignee)

Comment 17

5 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #13)
 
> It's a tough call, Hub.  I think that may warrant a bug on it's own.

Filed bug 867829 for that.

Updated

5 years ago
Whiteboard: c=performance → c=

Updated

4 years ago
Whiteboard: c= → c= s=2013.06.14 ,

Updated

4 years ago
Duplicate of this bug: 900313

Comment 19

4 years ago
I think this issue is not resolved yet.
Applying patch from https://bugzilla.mozilla.org/show_bug.cgi?id=867829 works pretty good for crashes of application but not for b2g.

Naoki, would you please test with steps in https://bugzilla.mozilla.org/show_bug.cgi?id=900313
The patch from 867829 can't handle crash of b2g process.
It means that crash dump of b2g could be submitted even if user set "Never send a report" from setting menu.
Flags: needinfo?(nhirata.bugzilla)
I tested this out with v08m base + our gecko/gaia and the crash report does not get submitted nor deleted.

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/aff662053ee8
Gaia   ddb922ed002e88d01f71199da32ff75911b455b2
BuildID 20130801070210
Version 18.0

I will be filing a bug in regards to getting the system crash to delete.
Flags: needinfo?(nhirata.bugzilla)

Comment 21

4 years ago
Please test this with leo v10a version recently uploaded.
It contains a patch on bug 900595.(It's not applied to central yet but in review+)
I think, this can be fixed with that.
You need to log in before you can comment on or make changes to this bug.