If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<table frame=void> has borders, should not

VERIFIED FIXED in M11

Status

()

Core
Layout: Tables
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: b9678050, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: MAKINGTEST klein_sh@inter.net.il, URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Checked with both M6 and 1999061608 builds at http://www.2a.ru on Windows NT 4.0
SP3. The above mentioned site works fine in Navigator3/4 and various Explorer$.
Tried on various machines with similiar configuration (may well be video
driver's problem, but it works fine in other browsers).

Updated

19 years ago
Assignee: rickg → karnaze

Comment 1

19 years ago
Running the Rick Autofilter to move this to karnaze. Chris -- perhaps this one
can go to pollman?
(Assignee)

Updated

19 years ago
Assignee: karnaze → pollmann
Component: Layout → HTMLFrames
(Assignee)

Comment 2

19 years ago
Reassigning frameset/iframe bugs to Eric.

Comment 3

19 years ago
look like bug # 7477

Updated

19 years ago
Whiteboard: MAKINGTEST klein_sh@inter.net.il

Comment 4

19 years ago
This page looks good to me with one exception, all the table borders are shown.
After narrowing this down a bit I came up with this minimal test case:

<html>
 <body bgcolor=white>
  <table frame=void>
   <tr><td>Foo</td></tr>
  </table>
 </body>
</html>

The borders that we render should not be there according to w3's spec:

frame = void|above|below|hsides|lhs|rhs|vsides|box|border [CI]
      This attribute specifies which sides of the frame that surrounds a table
      will be visible. Possible values:
            void: No sides. This is the default value.

I'll attache a test case.
Assignee: pollmann → karnaze
Summary: Frames are not rendered correctly (completely messed up) → <table frame=void> has borders, should not

Comment 5

19 years ago
Created attachment 917 [details]
Minimal test case
(Assignee)

Updated

19 years ago
Assignee: karnaze → pollmann
(Assignee)

Comment 6

19 years ago
Reassigning to Eric.
(Assignee)

Updated

19 years ago
Assignee: pollmann → karnaze
Component: HTMLFrames → HTMLTables
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
(Assignee)

Comment 7

19 years ago
Changing component from HTML Frames and accepting bug.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

18 years ago
Fixed with 9/13 checkins.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
Test case is working in the latest build (Sept 16th).
You need to log in before you can comment on or make changes to this bug.