Table row background overwrites table border

VERIFIED FIXED in Future

Status

()

Core
Layout: Tables
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Bradley Grainger, Assigned: karnaze (gone))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
When a table row is given a background colour, that background colour is painted
over the table border on the right-hand side. This happens whether CSS or HTML
attributes are used to set the border for the table and background colour for
the row.
HTML 4.01 Strict testcase: http://cryo.gen.nz/mozilla1.html
HTML 4.01 Transitional testcase: http://cryo.gen.nz/mozilla2.html
worksforme, linux build 2001-07-09-21
Created attachment 41773 [details]
screenshot
(Reporter)

Comment 3

17 years ago
worksforme with build 2001062815 (Mozilla 0.9.2) on Windows 2000.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
 This bug is not fixed because in the testcases with both doc types "strict" and 
"loose" DTD's the red background color overwrites the borders which it should 
not do. The problem appears in both CSS and HTML attributes. Reopening this bug. 
Please mark this bug resolved if you have a valid reason
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

16 years ago
Created attachment 64420 [details]
testcase with doc type loose DTD

Comment 6

16 years ago
Created attachment 64421 [details]
testcase with doc type strict DTD
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
Amar which border do you have in mind, the cell border or the outer table
border? Even with magnifier this bug is wfm. I see the same as the screenshot
attached by boris, whats wrong?

Comment 8

16 years ago
 Bernd, when I said "background color overwrites the borders" I should have said 
"cell borders". The bg color still overwrites the space between the cell border 
and table outer border which I think it should not. I think IE is rendering it 
correctly.

Comment 9

16 years ago
Amar please have a look at the spec and not IE. We render as required by the
spec. See the discussion at bug 46268.

Comment 10

16 years ago
Both testcases trigger Standard mode rendering. Also, amar, your "strict" 
testcase has an incorrect doctype; you're using the Transitional PI with the 
Strict URL.
See http://mozilla.org/docs/web-developer/quirks/doctypes.html
and http://www.w3.org/TR/html401/struct/global.html#h-7.2

re: cellspacing - you may want to take a closer look at 4510

Bradley - From your comments, I gather that this is a duplicate of bug 86220? 
(fixed a while ago) Is that correct?
OS: Windows 2000 → All
Hardware: PC → All

Updated

16 years ago
Target Milestone: --- → Future

Comment 11

16 years ago
fantasai: didn't we fix this? along with your patch for bug 4510

Comment 12

16 years ago
Actually, I think you fixed it when you fixed 86220--note that the reporter 
marked it worksforme in July. And coloring the cellspacing affected both the 
right and left sides, not just the right as reported here. But, either way, it 
is fixed.

Comment 13

16 years ago
marking fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
 Both the testcases works fine now. Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.