When building, I now get "configure: 3625: test: Illegal number:" (or "test: : integer expression expected")

RESOLVED FIXED in mozilla21

Status

defect
RESOLVED FIXED
7 years ago
Last year

People

(Reporter: dholbert, Assigned: glandium)

Tracking

Trunk
mozilla21
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
When building, I now get this output during the initial configure run:
 0:00.82 /scratch/work/builds/mozilla-inbound/mozilla/configure: 3625: test: Illegal number:
 0:00.82 /scratch/work/builds/mozilla-inbound/mozilla/configure: 3626: test: Illegal number:
I get similar output for js/src/configure slightly later.

Those line-numbers correspond to the first two lines of this chunk from my configure file -- the GCC_MAJOR_VERSION and GCC_MINOR_VERSION checks:
>    if test "$GCC_MAJOR_VERSION" -eq 4 -a "$GCC_MINOR_VERSION" -lt 4 ||
>       test "$GCC_MAJOR_VERSION" -lt 4; then
>        { echo "configure: error: Only GCC 4.4 or newer supported" 1>&2; exit 1; }
>    fi

I tried deleting my configure file and letting it be re-generated -- didn't help.  I suspect GCC_MAJOR_VERSION and GCC_MINOR_VERSION aren't defined...?

I'm on Ubuntu 12.10 x86_64, using GCC 4.7.2

Pretty sure this only started recently.  Looks like this chunk of configure.in was changed in the last week, in bug 833627, so I'm speculatively marking this as blocking that bug.
Reporter

Comment 1

7 years ago
I confirmed that bug 833627 introduced this.

In a build updated to b9f778ff6697 (the last cset on that bug), I see the "Illegal number" message during the first 100 lines of output, when I delete my objdir & 'configure' and run ./mach build.

In a build updated to 3c5e676ed5b0 (the parent of that bug's first cset), I see no such message.
Reporter

Comment 2

7 years ago
We get this in TBPL logs, too, though there it looks like this:

{
checking for windres... no
checking how to run the C preprocessor... /builds/slave/try-lnx64-dbg/build/configure: line 3727: test: : integer expression expected
/builds/slave/try-lnx64-dbg/build/configure: line 3728: test: : integer expression expected
}
https://tbpl.mozilla.org/php/getParsedLog.php?id=19259497&tree=Try
Reporter

Updated

7 years ago
Summary: When building, I now get "configure: 3625: test: Illegal number:" → When building, I now get "configure: 3625: test: Illegal number:" (or "test: : integer expression expected")
Assignee

Updated

7 years ago
Assignee: nobody → mh+mozilla
Comment on attachment 708011 [details] [diff] [review]
Fix gcc version test from bug 833627 to be properly quoted by m4

Review of attachment 708011 [details] [diff] [review]:
-----------------------------------------------------------------

Oh, m4, you so crazy.
Attachment #708011 - Flags: review?(ted) → review+
https://hg.mozilla.org/mozilla-central/rev/f54c2ac62480
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.