Closed Bug 836211 Opened 7 years ago Closed 7 years ago

Common organize options are still enabled on the downloads view when a previous view had focus

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 21
Tracking Status
firefox20 --- verified

People

(Reporter: simona.marcu, Assigned: mano)

References

Details

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130129 Firefox/21.0
Build ID: 20130129030851

Steps to reproduce:
1. Launch Firefox and perform several downloads.
2. Open the Downloads View using the keyboard shortcut (Ctrl/Cmd+ J on Windows and Mac OS X or Ctrl+Shift+Y on Ubuntu)
3. Click on the Bookmarks Toolbar and after that, in the right side click on any of the bookmarks
4. Move the focus from the Library window
5. Focus the Downloads View again by using the keyboard shortcut
6. Click on the Organize button to see the options.

Expected results:
New bookmark, New folder, New separator and Move options are disabled.

Actual results:
New bookmark, New folder, New separator and Move options are enabled.

Note: Reproducible also on the latest Aurora.
Blocks: 832949
Comment on attachment 708208 [details] [diff] [review]
patch

Review of attachment 708208 [details] [diff] [review]:
-----------------------------------------------------------------

please request Aurora approval once this lands.
Attachment #708208 - Flags: review?(mak77) → review+
Summary: Common organize options are still enabled → Common organize options are still enabled on the downloads view when a previous view had focus
https://hg.mozilla.org/integration/mozilla-inbound/rev/18638a787876
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 21
Comment on attachment 708208 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): downloads panel feature
User impact if declined: some commands in menus are wrongly enabled
Testing completed (on m-c, etc.): m-i
Risk to taking this patch (and alternatives if risky): minor (it's a focus call)
String or UUID changes made by this patch: none
Attachment #708208 - Flags: approval-mozilla-aurora?
Comment on attachment 708208 [details] [diff] [review]
patch

Low risk uplift of a new Fx 21 feature . Adding qawanted,verifyme for verification here,
Attachment #708208 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: simona.marcu
https://hg.mozilla.org/mozilla-central/rev/18638a787876
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified as fixed on Firefox 20 RC: - Common organize options are enabled on the downloads view when a previous view had focus.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:
Build ID: 20130326150557

Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.