Last Comment Bug 836294 - nsIMediaDevices (MediaEngineAudioSource and MediaEngineVideoSource) leak after using gum with UI
: nsIMediaDevices (MediaEngineAudioSource and MediaEngineVideoSource) leak afte...
Status: RESOLVED FIXED
[getUserMedia][blocking-gum+][MemShri...
: mlk
Product: Core
Classification: Components
Component: WebRTC: Audio/Video (show other bugs)
: 17 Branch
: All All
: P1 normal (vote)
: mozilla21
Assigned To: [:jesup] on pto until 2016/7/5 Randell Jesup
: Jason Smith [:jsmith]
Mentors:
Depends on: 815002
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-30 07:44 PST by [:jesup] on pto until 2016/7/5 Randell Jesup
Modified: 2013-02-06 03:41 PST (History)
5 users (show)
jsmith: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't drop array of media devices on the floor (3.26 KB, patch)
2013-01-30 07:45 PST, [:jesup] on pto until 2016/7/5 Randell Jesup
bzbarsky: review+
Details | Diff | Review

Description [:jesup] on pto until 2016/7/5 Randell Jesup 2013-01-30 07:44:06 PST
When using mozGetUserMedia, if the UI is enabled we leak a copy of every media source device and an nsTArray (and perhaps some related objects).  We don't see it in the mochitests as they suppress the permission UI.

Caused by copying an allocated nsTArray<nsCOMPtr <...> >, which is then dropped on the floor.
Comment 1 [:jesup] on pto until 2016/7/5 Randell Jesup 2013-01-30 07:45:04 PST
Created attachment 708131 [details] [diff] [review]
Don't drop array of media devices on the floor
Comment 2 Boris Zbarsky [:bz] (Out June 25-July 6) 2013-01-30 07:49:16 PST
Comment on attachment 708131 [details] [diff] [review]
Don't drop array of media devices on the floor

r=me
Comment 3 [:jesup] on pto until 2016/7/5 Randell Jesup 2013-01-30 08:03:25 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/cabffed38ccc
Comment 4 Ryan VanderMeulen [:RyanVM] 2013-01-31 13:39:18 PST
https://hg.mozilla.org/mozilla-central/rev/cabffed38ccc

Note You need to log in before you can comment on or make changes to this bug.