Mozilla displays nothing

VERIFIED DUPLICATE of bug 64888

Status

VERIFIED DUPLICATE of bug 64888
18 years ago
2 years ago

People

(Reporter: betz2010, Assigned: ddrinan0264)

Tracking

1.0 Branch
psm2.0
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Go to the URL http://www.askocs.ch with IE/Netscape old. No problems, the site
will redirect you to a https site. But with Mozilla nothing happens. 
I'm sure I could provide you with more information about the server etc. if
needed (I'm not the webmaster, but this is a server of our company.)
The site is timing out for me when I try to access it.  Could you attach the 
HTML it returns (together with the HTTP headers if possible) using 
http://bugzilla.mozilla.org/createattachment.cgi?id=83630 ?
(Reporter)

Comment 2

18 years ago
I'm not able to connect to the site with IE/Netscape old anymore. It seems to me
that they have taken the site down now, but I'm sure not for long (I guess the
site will be back next week.)
I will attach the HTML files at tuesday (when I'm back at work).
(Reporter)

Comment 3

18 years ago
I'm sorry, but you can't test the site because it's (at the moment) only visible
within our network(Mozilla displays nothting nevertheless). But the site will be
online in two or three weeks. I can then attach the HTML files but I'm almost
100% sure that wrong HTML isn't the problem, the site is visible locally at my
computer....
So, close this bug and open new one when you can test the site? Or should this
bug stay open?
Let's keep this open and comment/attach as more info becomes available.
Keywords: qawanted
(Reporter)

Comment 5

18 years ago
I've deactivated TLS in the preference menu because of a post from asa at
slashdot -> this fixed the problem, Mozilla now connects to the site!! Asa said
that this problem is because of a wrong server configuration, can somebody give
me more information on that topic because then we could fix this at our servers.
thanks!
Bob, what's our TLS shpiel?  Could you let Thomas know what he should 
do?

Comment 7

18 years ago
Thomas, the basic spiel is that several servers implement the fallback from TLS
(or SSL 3.1) to earlier protocols incorrectly. Mozilla follows the
specification, but since these servers do not we have problems connecting to
them. I don't believe it is a server configuration problem but is due to bugs in
the SSL implementation of the servers themselves. The work around is to turn off
TLS so we do not try to connect to the 'bad' servers using TLS. Currently TLS is
turned on by default, but a patch is going in (has gone in?) that will change
the default to have TLS turned off so we can work with these broken servers.

The tracking bug on this is http://bugzilla.mozilla.org/show_bug.cgi?id=59321

Thomas, please report the type of server your site is using so it can be
reported in the tracking bug so the server vendors can be notified to correct
their SSL implementations.

This should prolly be confirmed, Product->NSS, Component->Libraries,
Platform->All, OS->All

Comment 8

18 years ago
updating bug.
Assignee: asa → wtc
Status: UNCONFIRMED → NEW
Component: Browser-General → Libraries
Ever confirmed: true
Product: Browser → NSS
QA Contact: doronr → sonmi
Version: other → 3.0

Comment 9

18 years ago
This is a duplicate of PSM bug #64888.  I am changing
the Product to PSM and markingg the bug as a duplicate.
Assignee: wtc → ddrinan
Component: Libraries → Client Library
Product: NSS → PSM
QA Contact: sonmi → junruh
Target Milestone: --- → 2.0
Version: 3.0 → 2.0

Comment 10

18 years ago

*** This bug has been marked as a duplicate of 64888 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 11

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 12

18 years ago
The site is running on a Domino Server, Version 5.0.6A. Webserver runs on NT4 SP6A.
Hope this helps!
(again, the site is not accessible now) 

Updated

18 years ago
Keywords: qawanted

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.0 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.