Don't CC or ForgetSkippable before the first normal GC run

RESOLVED DUPLICATE of bug 836457

Status

()

RESOLVED DUPLICATE of bug 836457
6 years ago
6 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Snappy])

(Reporter)

Description

6 years ago
We should make sure to not gc before the first paint, if possible, since that will delay the first paint needlessly.  We may also get into a situation where the startup is taking too long, and we end up GCing making it take even longer.
Generally I think we wait ten seconds before GCing at startup, which is longer than the normal period. We could increase this timer, but hopefully not many people's startup takes longer than 10 seconds. Also, the first GC is usually pretty fast.
The first CC is usually pretty huge...
Also if you are looking at this, you want to look at when the first CC is done, as if it hasn't had a GC before it, it will force one.  So if say we're not delaying the CC properly, then we end up GCing right away too.
First CC shouldn't happen sooner than 6s after startup unless GC runs while doing some skippability
stuff, in which case it could happen as soon as 2s after GC.
(Reporter)

Comment 5

6 years ago
So, given these comments, is this bug INVALID?
Unless you've seen it happen earlier than 6s, or if that is too soon.

Though we should probably bump back the CC so its delay is longer than the GCs.  I think that's why I always get 1 CYCLE_COLLECTOR_NEED_GC right after startup.
Perhaps we could start the CC timer only after the first GC.
(Reporter)

Comment 8

6 years ago
(In reply to comment #6)
> Unless you've seen it happen earlier than 6s, or if that is too soon.

Nah, Boris and I were just wondering about this on IRC.

> Though we should probably bump back the CC so its delay is longer than the GCs.
>  I think that's why I always get 1 CYCLE_COLLECTOR_NEED_GC right after startup.

Feel free to morph this bug for that purpose if needed.
Assignee: general → nobody
Component: JavaScript Engine → XPCOM
OS: Mac OS X → All
Hardware: x86 → All
Summary: Do not gc before the first paint → Don't CC or ForgetSkippable before the first normal GC run
Um, I filed Bug 836457.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 836457
You need to log in before you can comment on or make changes to this bug.