high CPU usage on Wiktionary

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Brent, Unassigned)

Tracking

({perf, regression})

16 Branch
x86_64
All
perf, regression
Points:
---

Firefox Tracking Flags

(firefox18-, firefox19-, firefox20-, firefox21-, firefox-esr17- affected)

Details

(Whiteboard: Regressed by Bug 575294, URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130119055004

Steps to reproduce:

Simple.  Start browser, go to www.wiktionary.org.


Actual results:

CPU usage for 1 core goes to maximum.  (I saw 25% usage on a quad core system, and 50% usage on a dual core.)  CPU usage stays high until the user scrolls down and reaches the line that says "Other languages".  If the user reloads the page, CPU usage goes back up to maximum.

I tried Firefox 15, and did not see this problem.
(Reporter)

Updated

6 years ago

Comment 1

6 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/bf37951c1104
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120623031143
Bad:
http://hg.mozilla.org/mozilla-central/rev/e21173ed2c38
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120623053647
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bf37951c1104&tochange=e21173ed2c38


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/80b8680bda1c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120622175046
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c35d2d3071ac
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120622182843
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=80b8680bda1c&tochange=c35d2d3071ac

In local build
Last Good: 23f5c88adb8f
First Bad: 612ee5c6300d

Triggered by:
	612ee5c6300d	Mats Palmgren — Bug 575294. part=3/5 r=roc
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout
Ever confirmed: true
Keywords: perf, regression
OS: Linux → All
Product: Firefox → Core
Whiteboard: Regressed by Bug 575294
Version: 18 Branch → 16 Branch

Comment 2

6 years ago
http://hg.mozilla.org/mozilla-central/rev/677e87c11252
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20130130 Firefox/21.0 ID:20130130030907
It is worse on Windows.
Option of select tag cannot expand by click dropdown marker until I scroll a page.
status-firefox-esr17: --- → affected
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?
tracking-firefox-esr17: --- → ?
Component: Layout → Layout: Form Controls

Comment 3

6 years ago
Created attachment 708319 [details]
windbg log (High CPU usage after complete loading page)

Comment 4

6 years ago
Created attachment 708321 [details]
windbg log(when click dropmarker of select tag)

Updated

6 years ago
Attachment #708319 - Attachment description: windbg log → windbg log (High CPU usage after complete loading page)
Assignee: nobody → matspal
Blocks: 575294

Comment 5

5 years ago
We'd accept a low risk uplift once found.
tracking-firefox18: ? → -
tracking-firefox19: ? → -
tracking-firefox20: ? → -
tracking-firefox21: ? → -
tracking-firefox-esr17: ? → -
Is this still a problem?
(Reporter)

Comment 7

5 years ago
Not a problem any more, as far as I can tell.  Checked Firefox 22 and 23, and could not reproduce.  Some change before Firefox 22 seems to have fixed it.
WFM, FF22, 23 and trunk on Linux64.
Alice, can you still reproduce this bug?
Flags: needinfo?(alice0775)

Comment 10

5 years ago
Unfortunately?, The site changed something...
I cannot reproduce the problem in the BAD build in comment#1.
And of course, I cannnot reproduce in Firefox17.0.8esr Firefox23.0a1 and later.
Thanks for testing.  I don't see much value in keeping this bug open then.
Assignee: matspal → nobody
Flags: needinfo?(alice0775)

Comment 12

5 years ago
Fixed by www.wiktionary.org.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.