Certain Submenus don't work on Mac OS X

VERIFIED FIXED in mozilla0.9.5

Status

()

Core
XUL
P1
critical
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: hsivonen, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({pp})

Trunk
mozilla0.9.5
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+,OSX+)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build ID: 2001-05-30 FizzillaCFM

Steps to reproduce:
1) Open a document in Editor.
2) Try to use commands in the submenus of the Format and Table menus.

Actual results:
The commands do nothing.

Expected results:
Expected the commands to work.

Comment 1

17 years ago
cc: twalker, do you see this?

Comment 2

17 years ago
sorry for spam, cc: shrir also.

Comment 3

17 years ago
Commmercial build 2001-06-01-04-trunk is fine.  No problems using functionality 
in those menus.  I checked linux and windows also, just to be sure. They are 
fine too.

Comment 4

17 years ago
Henri, please recheck...download latest build and try again...

Comment 5

17 years ago
cannot repro on any platform, marking wfm
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
verified in 6/1 build.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 7

17 years ago
did anyone happen to notice the platform before you closed it WFM? did anyone
try it on the reporter's platform?

Comment 8

17 years ago
Reopening based on pink's comments.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

17 years ago
Now please test and verify on the reported platform.
Summary: Editor submenus don't work → Editor submenus don't work on Mac OS X
(Reporter)

Comment 10

17 years ago
I tried again (with the same build--it is the newest one available). The
commands in submenus still don't work for me in FizzillaCFM on Mac OS X.

However, they do work in the Classic build for me, too. So this is Mac OS X only.

Comment 11

17 years ago
can someone please verify on Mac OS X.

Comment 12

17 years ago
Confirming issue is only occuring with the carbon OS X Fizzila build. Tested
with Fizzila 5/30 build under Mac OS X 10.0.3.

Updated

17 years ago
Keywords: pp

Comment 13

17 years ago
well Simon is Mr. Mac -- here ya go
Assignee: beppe → sfraser
Status: REOPENED → NEW
Priority: -- → P2
Target Milestone: --- → mozilla0.9.2

Updated

17 years ago
Whiteboard: OSX

Updated

17 years ago
Whiteboard: OSX → [mac OSX]

Comment 14

17 years ago
Seems like a Carbon menu thing; cc beard.
(Assignee)

Comment 15

17 years ago
beta stopper
Whiteboard: [mac OSX] → OSX++
(Assignee)

Comment 16

17 years ago
i'll take this.
Assignee: sfraser → pinkerton
(Assignee)

Comment 17

17 years ago
this turns out to be an OS bug in the Carbon menu manager. Calling
::DisableMenuItem() on a submenu from that menu's open event handler royally
screws up the menu manager.

I'm in contact with apple. Currently, the only workaround is to not disable any
menu items in a submenu on osx. This would only affect composer, it seems.
Status: NEW → ASSIGNED
(Assignee)

Comment 18

17 years ago
hrm, ok, that isn't all of it. it still locks up, just now it takes a lot more
to do it.
(Assignee)

Updated

17 years ago
Keywords: nsBranch
Target Milestone: mozilla0.9.2 → mozilla0.9.3
(Assignee)

Updated

17 years ago
Whiteboard: OSX++ → OSX++, PDT+

Comment 19

17 years ago
Mike, this is PDT+ bug. Tomorrow, on Tuesday, we'll try to build the first RTM
candidate. It would be good, if this could be resolved ASAP.
(Assignee)

Comment 20

17 years ago
i'm downgrading this. apple is looking into the menu manager problems and has 
already found one, but not for osx. I don't think it's necessarily our problem, 
and it seems to only be composer right now.

we should reinvestiage after beta.
Whiteboard: OSX++, PDT+ → OSX+
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 21

17 years ago
There are some mail submenu items that don't work (bug 91914)--related?
(Assignee)

Updated

17 years ago
Blocks: 91914
(Assignee)

Comment 22

17 years ago
Apple has identified and fixed some bugs in the Carbon MenuManager on both 9 and 
X that mozilla uncovered. when we get newer seeds with the fixes, i'll revisit.
Component: Editor → XP Toolkit/Widgets: Menus
Summary: Editor submenus don't work on Mac OS X → Certain Submenus don't work on Mac OS X
Whiteboard: OSX+ → OSX++

Comment 23

17 years ago
*** Bug 95663 has been marked as a duplicate of this bug. ***

Comment 24

17 years ago
Can someone please test and list exactly what submenu items don't work?
There are some other "submenu commands not working" bugs that are not Mac 
specific and this is causing confusion (e.g., see bug 93653).
found this while skimming thru os x bugs...should check hierarchical menus in
browser, just to be sure. nbaca, have you encountered this in mailnews windows?
let me know if you need access to an os x box --my mac dualboots.

unless of course, pink's 2001-06-15 18:54 comments still stand and this is
editor-only...

has anyone encountered this problem with hierarchical *context* menus? just
curious.
Keywords: nsBranch → nsbranch
erm, i meant pink's 2001-07-06 12:17 comments.
(Assignee)

Comment 27

17 years ago
*** Bug 97160 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Keywords: nsenterprise+

Comment 28

17 years ago
Have we tested this with the latest seed from Apple?
(Assignee)

Comment 29

17 years ago
yes, and it still doesn't work, though with carbonlib 1.4 it no longer takes out 
the machine. as a result, i can now debug it. that's what i'm working on in the 
next day or two.
(Assignee)

Comment 30

17 years ago
*** Bug 97151 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 31

17 years ago
ok, we're in a world of hurt here. As of CarbonLib1.4, even regular submenus 
(ones that don't make changes in their onCreate handlers) only work once. It 
appears that the second time a submenu is accessed, ::MenuSelect() freaks and 
returns a menuID that's way out of bounds for either our menus or apple's 
internal ids.

I'm talking to apple about this, and we're gonna need some help here.

Comment 32

17 years ago
This bug is a test stopper for intennational since we cannot test charsets in
mail, editor... I'm afraid we are going to find more bugs when this one is
fixed, and it may be too late... Can you raise priority in this bug? Anything we
can do to help?

Comment 33

17 years ago
cc: petersen
(Assignee)

Comment 34

17 years ago
i am working with apple on this, but i'm going to be out for about a week and a 
half starting wednesday. unfortunately, dagley and sfraser are out the end of 
this week as well. One of them should probably own this issue until i get back 
online in virginia.

my best guess is that there are bugs in the carbon Menu Manager that we are 
hitting. I'm not sure how we could change our code w/out turning off 
functionality.
(Assignee)

Updated

17 years ago
Keywords: nsbranch → nsbranch+
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Comment 35

17 years ago
the more i dig, the more i find wrong. we appear to be clearing out the menu and 
any of our internal menu stuctures as soon as the mouse is released on an item 
(when the menu goes away). This makes it impossible for us to later find the item 
in a submenu -- all the submenus and items in that submenu have been destroyed!

I'm working on trying to cache the information from the event handlers (before 
menuSelect returns, by then it's too late), but there are OS bugs in the tracking 
handlers and no carbon event when an item has been selected.

calgon, take me away!
(Assignee)

Comment 36

17 years ago
after talking a bit to beard, it seems that the real thing to do is eschew all 
these peripheral issues and do the following:

for every menu item, assign a unique 32-bit command id. make a map from this ID 
to the corresponding nsIMenuItem. install a carbon event handler to process this 
command event when the item is selected and then just go straight to the menuItem 
from there to execute the command. 

This gets rid of all the ugly code that scans over our menus and submenus looking 
for menu ids and items. I'll get on this as soon as i get back to va.
(Assignee)

Comment 37

17 years ago
the reason why we're tearing down the Table menu prematurely is because of 
hyatt's bug that the oncreate event bubbles. since both the table menu and the 
submenu have oncreate events, the Table menus thinks it should be rebuilt every 
time the Insert submenu is opened.

still playing...
(Assignee)

Comment 38

17 years ago
i have it working 95%. i'll submit a patch tomorrow.

Comment 39

17 years ago
so do you remove ids from the map and create new ones each time we do a menu
tear down/build cycle? Why is this an issue at all in the dynamic menu world, we
should be getting equivalent behavior, no?

Comment 40

17 years ago
*** Bug 98279 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 41

17 years ago
saari, i have no idea what you just said ;)
(Assignee)

Comment 42

17 years ago
Created attachment 48322 [details] [diff] [review]
[patch] fixes our problems and works around os bugs
(Assignee)

Comment 43

17 years ago
ok, looking for r/sr here. it looks pretty good on osx. there are other issues on 
os9, but those are apple bugs and we're not qualifying for os9.

i tried the composer table insert menu (the main reason for this bug) and it 
works. I also tried the character encoding menus and they seem to work as well. 
did a little bit of testing on os x [2001.09.04.08-comm]. olgam, could you let
us know if there are other menu items that are affected? thx!

* submenus from the main menu in the mailnews main window [eg, submenus from
View, Message] and editor window don't work.
* the Message submenu items [from main menu] don't seem to work for a mail
standalone window.
* submenus from the main menu in the browser seem fine.
* submenus [for context menus] in editor, mailnews and mail standalone windows
appear fine.
(Assignee)

Comment 45

17 years ago
sairuh, all mail menus work just fine for me. i couldn't test standalone message 
window (networking no workie on my MP box), but i checked message compose. 
coudln't find a single proble.

we might have to require the latest version of OSX (after 10.0.4) for certain 
bugs in the menu manager to be fixed, though it's strange that composer menus 
worked for you yet mail didn't
yeah, prolly best to revisit/retest once the official-post-10.0.4 upgrade is
available.

olgam, let me know if/when i could help you test this further.

Comment 47

17 years ago
*** Bug 98810 has been marked as a duplicate of this bug. ***

Comment 48

17 years ago
I have Mac OSX 10.0.4 and still see problems with the View menus which have
submenus in mail. (Logged as bug 99507) 
Is this a dupe?

Comment 49

17 years ago
*** Bug 99507 has been marked as a duplicate of this bug. ***

Comment 50

17 years ago
Anyone know when the next release of Mac OSx is available? 
Will it make our next release?
This makes many Mail menu submenus non-functional on branch for OSX :-(

Comment 51

17 years ago
Apple has publicly stated that Mac OS X 10.1 will ship in September.  Considering 
bugs in 10.0.4, such as this one, we may well end up requiring Mac OS X 10.1 for 
the release version of Mozilla/Netscape 6.x for Mac OS X.

Updated

17 years ago
Blocks: 98810
(Assignee)

Comment 52

17 years ago
*** Bug 99544 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 53

17 years ago
i need r/sr on this patch please.

Comment 54

17 years ago
Comment on attachment 48322 [details] [diff] [review]
[patch] fixes our problems and works around os bugs

sr=sfraser
Attachment #48322 - Flags: superreview+
QA Contact: sujay → sairuh

Updated

17 years ago
Blocks: 99544
(Assignee)

Comment 55

17 years ago
sairuh, i just tried my patch on 10.0.4 and all menus that you claim don't work
work perfectly for me. I guess we're not going to have to require 10.1 after
all. can anyone else verify this? Why are we getting such different results?

opt fizzila build, tree from 9/17/01, 10.0.4

Comment 56

17 years ago
r=saari
(Assignee)

Comment 57

17 years ago
Comment on attachment 48322 [details] [diff] [review]
[patch] fixes our problems and works around os bugs

from r=saari in bug
Attachment #48322 - Flags: review+

Comment 58

17 years ago
PDT+. Pls get it in by 3 am.
Whiteboard: OSX++ → PDT+,OSX+
(Assignee)

Updated

17 years ago
Severity: major → critical
Priority: P2 → P1

Comment 59

17 years ago
*** Bug 99544 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 60

17 years ago
*** Bug 100358 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 61

17 years ago
landed on trunk and branch. 

if you have specific menu problems after the 9/19/01 bits, please file new bugs. 
this has serious zombie potential and i don't want to see this bug reopened.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 62

17 years ago
I verified that Editor submenus work in build 2001091821. Thanks!
using 2001.09.19.04-branch on 10.0.4, tested thus far --and looks fine:

* menus and submenus from the browser main menubar
* menus and submenus from the editor main menubar

yet to do:

* context menus in browser
* context menus in editor

however, if anyone doesn't think verification of context menus is needed for
*this particular bug* do let me know. i'll definitely get to 'em --but how much
of a response i get here will affect how soon i'll get to 'em. (it'll get to the
head of the queue if the response is ,"yes, it's relevant here!" :)
(Assignee)

Comment 64

17 years ago
don't bother verifying context menus. they're not native, and thus would not 
suffer from any of these problems. any problems you find there would be totally 
different bugs.
pink: okidoke! vrfy'ing da branch. if someone beats me to the trunk, go ahead
and mark this verified and remove the vtrunk kw...
Keywords: vtrunk
checked the browser menus: vrfy fixed on the trunk [2001.10.03.20] on 10.0.4.

sujay, could you vrfy this for the composer main menus/submenus on Mac OS 10.x? thx!
QA Contact: sairuh → sujay
oh i did find one problem: crash opening an IM compose window. filed that as
http://bugscape.mcom.com/show_bug.cgi?id=10102.

Comment 68

16 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 69

16 years ago
Confirming Table and Format sub-menus are functional in the Oct 5th OS X build.

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: sujay → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.