Having methods named JS_NumberValue and JS::NumberValue might not be such a good idea

ASSIGNED
Assigned to

Status

()

ASSIGNED
6 years ago
6 years ago

People

(Reporter: Waldo, Assigned: Waldo)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
The names are perhaps a little bit too similar.  The semantics are subtly different (JS_NumberValue canonicalizes NaNs to the js_NaN pattern).  We should rename so the differences are much more obvious, or we should remove the version that doesn't canonicalize and just have every place canonicalize.  I don't know if we can just always canonicalize, or if that'll be a perf it.  We'll have to try it and see if there are any hot spots to care about, or something.
You need to log in before you can comment on or make changes to this bug.