[Settings] The string doesn't translate after changing language

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: arthurcc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.1 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
1. Title : The string doesn't translate after changing language
2. Precondition : 
3. Tester's Action : Setting - Phone lock - Passcode lock turn on - change any language
4. Detailed Symptom (ENG.) : The 'immediately' string doesn't change.
5. Expected : 
6. Reproducibility: Y
1)Frequency Rate : 100%
7. Gaia revision : f46757775e07d314913b4a5ae975fa131d1c7c4b
(Reporter)

Comment 1

6 years ago
Created attachment 708504 [details]
Screenshot
(Reporter)

Comment 2

6 years ago
Pleze check to translate all string of select popup.
Any string of select popup doesn't translate well.
(Reporter)

Updated

6 years ago
blocking-b2g: --- → leo?
Is this a regression?  QA can you confirm and also see if this happens with v1.1 shipping locales?
Keywords: qawanted
Specific case is blocking because of potential to lock yourself out of the phone. Otherwise, a string issue like this on a Settings subscreen would not normally hold a release back.
blocking-b2g: leo? → leo+
Assignee: nobody → arthur.chen
Created attachment 730120 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8849

Evelyn, please help the change. Feel free to merge it directly once you grant the review (hopefully :D).
Attachment #730120 - Flags: review?(ehung)
(In reply to lsblakk@mozilla.com from comment #3)
> Is this a regression?  QA can you confirm and also see if this happens with
> v1.1 shipping locales?

Just confirmed that this happens with v1.1
status-b2g18: --- → affected
Keywords: qawanted

Comment 7

6 years ago
Comment on attachment 730120 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/8849

r=me, look good. Thank you so much.
Attachment #730120 - Flags: review?(ehung) → review+
master: https://github.com/mozilla-b2g/gaia/commit/aac03bb8501f8a59536aa7da752074142552705d
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Uplifted commit aac03bb8501f8a59536aa7da752074142552705d as:
v1-train: a04db43fb8aaf92039aab9797123dceae5d9fd77
status-b2g18: affected → fixed
Nominated for tef? since it is the same as a tef+ bug (bug 859436).
blocking-b2g: leo+ → tef?
blocking-b2g: tef? → tef+
status-b2g18-v1.0.1: --- → affected

Comment 11

6 years ago
Phone lock is now fully localized. 
Verified fix on 

Unagi Build ID: 20130409070205
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/cfef36c0c8bc
Gaia: a80be95f553de517e5d8a159e04511cda5e38be4
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
v1.0.1:https://github.com/mozilla-b2g/gaia/commit/aff876b051c51d091cecf322b90c4f0093281b5e

Stas, I found some strings existed in settings.en-US.properties are not listed in other language files, for example, "availableSize". Could you help check it?
Flags: needinfo?(stas)
marking v1.0.1 as fixed basd comment 12
status-b2g18-v1.0.1: affected → fixed
(In reply to Arthur Chen [:arthurcc] from comment #12)
> Stas, I found some strings existed in settings.en-US.properties are not
> listed in other language files, for example, "availableSize". Could you help
> check it?

Arthur, how is this related to this bug?  Can you point to a specific language file that you checked?
Flags: needinfo?(stas)
I checked settings.zh-TW.properties. However, I was told that there is another repository for language files, so what I mentioned might not a real issue.
(In reply to Arthur Chen [:arthurcc] from comment #15)
> I checked settings.zh-TW.properties. However, I was told that there is
> another repository for language files, so what I mentioned might not a real
> issue.

Correct.  Just FYI:

v1-train locales: https://hg.mozilla.org/gaia-l10n/
v1.0.1 locales: https://hg.mozilla.org/releases/gaia-l10n/v1_0_1
You need to log in before you can comment on or make changes to this bug.