composer crashes on pages with bgcolor when saving in html source view

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Editor
P1
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Aleksander Adamowski, Assigned: rubydoo123)

Tracking

({crash})

Trunk
mozilla0.9.2
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build ID: 2001053120
OS: tested on Win 2000 and Linux
To reproduce:
1. Go to http://office.altkom.com.pl/mozilla/composer/crash
2. Right-click on "With bgcolor" and select "Edit link in composer"
3. Switch to HTML source view
4. Do any change (you can eg. delete one of the space characters)
5. Do File->Save
Expected behaviour: Page Title dialog show up
Observed behaviour: Mozilla crashes. Talkback IDs:
Win2K: 
TB31188526K
TB31188438G
TB31185237E
Linux:
TB31192214E

The second page (the "Without bgcolor" one) differs from the first in only one 
detail:
instead of 
<body bgcolor="#ffffff">
, it has
<body>
.

If you edit the second page (no_bgcolor.html)in composer everything is ok.
So this problem applies only to pages with body bgcolor set.

There's one more problem that occurs only under Linux and only with local 
files: Composer crashes when opening any of the two pages shown here. I'll file 
a separate bug on this.
(Reporter)

Comment 1

17 years ago
Adding crash to keywords
Keywords: crash
(Reporter)

Comment 2

17 years ago
I filed a bug on the second issue (Linux Composer crashing when opening those 
files): bug 83676
(Reporter)

Comment 3

17 years ago
Created attachment 36799 [details]
testcase (both html files, zipped)

Updated

17 years ago
Severity: major → critical
(Assignee)

Comment 4

17 years ago
using the build 2001053120 build on win98, I cannot reproduce this crash at all. 
Just ot make sure I followed your steps, this is what I did:
1. opened the file in the browser
2. moused over the 1st link, right-mouse click, and selected Edit Link in 
Composer
3. the link displayed in Composer, I selected the HTML Source mode tab, HTML 
Source mode displayed
4. selected to the right of the &lt;body bgcolor="#ffffff"&gt; and added this is 
a
5. selected SaveAs and I got the Title dialog and was able to save without a 
problem

am I missing something?
(Reporter)

Comment 5

17 years ago
You got the steps right. Strange, mine crashes everytime. Can you test it on
Win2000?
(Assignee)

Comment 6

17 years ago
will need to get QA to do that for you -- asking Sujayif he can try it on win2000

Comment 7

17 years ago
I can't repro this crash with my Win32 Debug build on WinNt 4 sp6a either.

Sujay or Shrir, do either of you have a Win2K machine that you can reproduce 
this crash on?

Comment 8

17 years ago
Here's the stack trace from talkback:


Trigger Type:  Program Crash 
Trigger Reason:  Access violation 
Thread ID:   
Call Stack:    (Signature = nsNodeInfoManager::GetDocument 4b580282) 
nsNodeInfoManager::GetDocument 
[d:\builds\seamonkey\mozilla\content\base\src\nsNodeInfoManager.cpp, line 285]
nsRuleNode::WalkRuleTree 
[d:\builds\seamonkey\mozilla\content\html\style\src\nsRuleNode.cpp, line 846]
nsRuleNode::GetListData 
[d:\builds\seamonkey\mozilla\content\html\style\src\nsRuleNode.cpp, line 737]
nsRuleNode::GetStyleData 
[d:\builds\seamonkey\mozilla\content\html\style\src\nsRuleNode.cpp, line 4466]
nsStyleContext::GetStyleData 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 394]
nsStyleContext::CalcStyleDifference 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 639]
CaptureChange 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1592]
FrameManager::ReResolveStyleContext 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 1682]
FrameManager::ComputeStyleChangeFor 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 2072]
nsCSSFrameConstructor::AttributeChanged 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 9955]
StyleSetImpl::AttributeChanged 
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1152]
PresShell::AttributeChanged 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4819]
nsDocument::AttributeChanged 
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 1676]
nsHTMLDocument::AttributeChanged 
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLDocument.cpp, line 
1284]
nsGenericHTMLElement::UnsetAttribute 
[d:\builds\seamonkey\mozilla\content\html\content\src\nsGenericHTMLElement.cpp, 
line 1738]
nsGenericElement::RemoveAttribute 
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1016]
nsHTMLBaseElement::RemoveAttribute 
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLBaseElement.cpp]
ChangeAttributeTxn::DoTransaction 
[d:\builds\seamonkey\mozilla\editor\base\ChangeAttributeTxn.cpp, line 73]
nsTransactionItem::DoTransaction 
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionItem.cpp, line 167]
nsTransactionManager::BeginTransaction 
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 
1062]
nsTransactionManager::DoTransaction 
[d:\builds\seamonkey\mozilla\editor\txmgr\src\nsTransactionManager.cpp, line 
124]
nsEditor::Do [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, line 493]
nsEditor::RemoveAttribute [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, 
line 1118]
nsEditor::CloneAttributes [d:\builds\seamonkey\mozilla\editor\base\nsEditor.cpp, 
line 2233]
nsHTMLEditor::RebuildDocumentFromSource 
[d:\builds\seamonkey\mozilla\editor\base\nsHTMLEditor.cpp, line 1712]
nsEditorShell::RebuildDocumentFromSource 
[d:\builds\seamonkey\mozilla\editor\base\nsEditorShell.cpp, line 2783]
XPTC_InvokeByIndex 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, 
line 139]
XPCWrappedNative::CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 
1837]
XPC_WN_CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp, 
line 1242]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 809]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2703]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 825]
nsXPCWrappedJSClass::CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 
970]
nsXPCWrappedJS::CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjs.cpp, line 427]
PrepareAndDispatch 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp, 
line 102]
SharedStub 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp, 
line 124]
nsControllerCommandManager::DoCommand 
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsControllerCommandManager
.cpp, line 184]
nsEditorController::DoCommand 
[d:\builds\seamonkey\mozilla\editor\base\nsEditorController.cpp, line 192]
XPTC_InvokeByIndex 
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp, 
line 139]
XPCWrappedNative::CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 
1837]
XPC_WN_CallMethod 
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp, 
line 1242]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 809]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2703]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 825]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 897]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3322]
nsJSContext::CallEventHandler 
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 937]
nsJSEventListener::HandleEvent 
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 140]
nsXBLPrototypeHandler::ExecuteHandler 
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeHandler.cpp, line 
430]
nsXBLWindowHandler::WalkHandlersInternal 
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowHandler.cpp, line 307]
nsXBLWindowKeyHandler::WalkHandlers 
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowKeyHandler.cpp, line 
132]
nsXBLWindowKeyHandler::KeyPress 
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowKeyHandler.cpp, line 
148]
nsEventListenerManager::HandleEvent 
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line 
1554]
nsXULDocument::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 
1997]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3658]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3650]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3650]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3650]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3650]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3650]
nsXULElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 
3650]
nsGenericElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1696]
nsHTMLTextAreaElement::HandleDOMEvent 
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLTextAreaElement.cpp, 
line 595]
PresShell::HandleEventInternal 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5515]


Registers: 
EAX: 02fe53d4
EBX: 0012cae0
ECX: 00000000
EDX: 00000000
ESI: 031ef5f8
EDI: 031ef658
ESP: 0012ca28
EBP: 0012ca60
EIP: 01e4237f cf PF af zf sf of IF df nt RF vm
IOPL: 0 
CS: 001b
DS: 0023
SS: 0023
ES: 0023
FS: 0038
GS: 0000
Command Line:  "G:\mozilla\mozilla-win32-talkback\bin\mozilla.exe"

Comment 9

17 years ago
I think the crashes you are seeing may have been caused by the same things that 
cause bug #83613. I believe the build 2001053120 you used was built just after 
the style system speedup landing, so you may have been seeing fallout from that.

Aleksander, is it possible for you to get a more recent nightly build and try 
this out before we mark it as a FIXED/WORKSFORME? I'd also retest bug #83676 
with a newer build, since it might be due to the same thing.

I can open local files just fine.

Comment 10

17 years ago
I cannot reproduce on Win2K...please try Kin's advice above.
(Reporter)

Comment 11

17 years ago
Confirming that this is fixed with latest builds. As to the other bug, I can't
check that because File->Open stopped working in Composer.
(Reporter)

Comment 12

17 years ago
False alert with that File->Open, it works.

Comment 13

17 years ago
Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Priority: -- → P1
Resolution: --- → FIXED
Target Milestone: --- → mozilla0.9.2

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 14

17 years ago
verified.
You need to log in before you can comment on or make changes to this bug.