Closed Bug 836803 Opened 8 years ago Closed 8 years ago

Can't scroll the certificate in the new NSS dialog service

Categories

(Firefox for Android :: General, defect)

21 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 21

People

(Reporter: tchevalier, Assigned: kats)

References

Details

Attachments

(2 files)

As described in bug 807606, install a certificate from http://www.cacert.org/index.php?id=3, then touch "view".

You currently can’t scroll to the bottom of the certificate.

Using a SGS2 and android 4.2.1
The first patch (https://bugzilla.mozilla.org/attachment.cgi?id=705571&action=diff) seemed to add a scrollView; what is missing?
Attached image Screenshot
Hmm, I'm not seeing a scroll bar at all... Even when I touch the screen. Nothing happen.
I am missing something?
I can reproduce this; I think I know the problem. Testing out a patch.
Attached patch PatchSplinter Review
I only applied the ScrollView on the case where the prompt dialog had multiple elements; it needs to be applied in the single-element case as well. I missed this during testing because I changed the view dialog from having multiple text fields to one "html" field.

Also moved the code into the try block for consistency.
Assignee: nobody → bugmail.mozilla
Attachment #708663 - Flags: review?(mark.finkle)
Attachment #708663 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/f75f99c52648
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Verified fixed on:
-build: Firefox for Android 22.0a1 (2013-02-20)
-device: Samsung Galaxy Nexus
-OS: Android 4.2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.