send later when the local mail folder directory doesn't exist silently fails

VERIFIED FIXED

Status

SeaMonkey
MailNews: Backend
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Judson Valeski, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I got into a situation where my local mail folder directory doesn't exist. I
wrote some mail in offline mode, then went online to send it. It appears as
though at no point was a mail message actually written out to disk (the
directory was never created, let alone an unsent message on disk), yet I never
had indication of failure. Ideally we should be forcing the recursive mail
directory creation if for whatever reason it doesn't exist when send later is
envoked.
(Assignee)

Comment 1

17 years ago
cc'ing Seth and Navin for review. The upcoming patch will cause an error to get
displayed, though it's not the right error (that would be up to JF - with my
patch, we display the message that the send succeeded but the copy to the sent
folder failed, even though we're offline and doing a send later- I'll file a bug
on that in a minute).

To recreate this bug, rename your Local Folders directory to Local Folders2
using the Windows File System Explorer, start up mozilla, go offline, compose a
new msg, and do a send later. W/o this fix, it just silently fails. with this
fix, you'll get the message I mentioned above.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

17 years ago
Created attachment 43518 [details] [diff] [review]
proposed fix

Comment 3

17 years ago
r=naving

Comment 5

17 years ago
Adding nsenterprise keyword.  Is this just for a missing local folders or will
this affect any situation where the sent folder doesn't exist?
Keywords: nsenterprise
(Assignee)

Comment 6

17 years ago
just local folders; we'll create the online imap folder.
(Assignee)

Comment 7

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
I am assuming this is only a Window's bug?

I noticed this doesn't work in Mac or Linux?
(Assignee)

Comment 9

17 years ago
no, it should be an xp bug.
OS: Windows 2000 → All
Hardware: PC → All

Comment 10

17 years ago
Commercial builds:
2001-08-15-09-trunk/ - nt 4.0
2001-08-15-14-trunk- linux 2.2, mac 9.0.4

Verified if you rename the Locals Folder directory
to new name, that when you do a send later, a error message
will appear (albeit the wrong error message) "The send
was successful, but copying to sent folder failed.."

On Mac it is very tricky to rename Local Folders directory.
As if you rename it, the Local Directory Path in 
Edit|Mail/News Account settings|Local Fodlers
gets updated in real time so I could not reproduce the
error message. If I renamed it, it would automatically map
to the new folder name. The only way I could test this, was
to delete the Local Folder's directory. 


Marking as verified.
Status: RESOLVED → VERIFIED
QA, can you re-verify this bug with a more recent buid (like today's). You
should now get a more valid error message. If it's not the case, you should file
a new bug. Thanks

Comment 12

17 years ago
Jean-Francois, I checked with these builds:
Commercial builds
2001082008 - win nt 4.0
2001082108 - linux 2.2, mac 9.0.4

Error message is indeed different now. Will put my comments
in your other bug, bug 92251
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.