Closed Bug 836826 Opened 8 years ago Closed 8 years ago

IonMonkey: Do truncation of constants and additions properly

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 841666

People

(Reporter: h4writer, Unassigned)

Details

Currently we can only truncate Constants smaller than 2^33, because we have no idea how many additions were between the double and the truncation. Currently 20 additions are allowed and truncations isn't possible as soon as number is bigger than 2^53, resulting in the maximum of 2^33.

This bug is to get the max. of 2^53.
What code is this intended to help on?
(In reply to David Anderson [:dvander] from comment #1)
> What code is this intended to help on?

Originally the code in bug 836102. We were using double math there, because some constants are doubles. We get away with the patch in that bug, as the constants are at max 2^33. But we could bump that... No actual example that is above 2^33, though.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 841666
Hmm, just realizing bug 841666 could solve this issue, but doesn't need to. Therefore keeping this open until I bug 841666 gets closed. This bug will get solved by it or will probably need the infrastructure added in that bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Reviewed bug 841666 and it indeed does this =D
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 841666
You need to log in before you can comment on or make changes to this bug.