Font rendering jagged on Windows 8

RESOLVED WORKSFORME

Status

()

Core
Graphics: Text
RESOLVED WORKSFORME
6 years ago
5 months ago

People

(Reporter: Tobi Reif, Unassigned)

Tracking

18 Branch
x86
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

Opened
http://www.tobireif.com/centerslate/
in Firefox 18 on Windows 8.


Actual results:

The rendered glyphs (of the large word "Centerslate") are jagged, see the screenshot at
http://www.tobireif.com/non_site_stuff/jagged_glyphs_firefox_windows.png
.


Expected results:

It would be great if the glyphs would be rendered smoothly (eg anti-aliased), on all platforms, by default.
Or there could be eg a prefixed font smoothing CSS property.
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Looks similar on Win7, too, with or without h/w acceleration.

The 'gasp' table in the font seems to call for symmetric grayscale smoothing, but what I'm actually seeing looks like standard ClearType, which does not do well with near-horizontal edges, which are the ones that look particularly bad here.

Note that comparing the page in other browsers is misleading, because the CSS also provides SVG versions of the fonts; as such, some browsers will be rendering those instead and so the rasterization is expected to be different. If you remove the SVG versions, so that all browsers are using the same (TrueType) outlines, cross-browser comparison will be more meaningful.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → Windows 8
And experimenting with Chrome, using the TrueType version of the font, confirms that it (correctly) uses grayscale smoothing, which makes for much better-looking shallow diagonals.
(Reporter)

Comment 3

6 years ago
Thanks for your replies!

It would be great if the glyphs would be rendered smoothly (non-jagged) by Firefox, for all font formats, on all platforms.
Blocks: 959409

Comment 4

5 months ago
http://www.tobireif.com/non_site_stuff/jagged_glyphs_firefox_windows.png fails, so I don't have a comparison - but I dont' see this on windows 7 using Firefox 60 nightly.

Do you still see thie problem?
Flags: needinfo?(tobi)
(Reporter)

Comment 5

5 months ago
I don't have a local Windows machine, but the rendering quality of the glyphs seems OK enough now:

https://s3.amazonaws.com/media.crossbrowsertesting.com/users/157403/snapshots/zd576e2337e92134479a.png
(at least on Windows 10)

Ideally someone with a local Windows machine (and a high-res screen) could check as well. (also on older Windows versions?)

(Bx the way: On Mac OS, Firefox renders the page http://www.tobireif.com/centerslate/ with impressive quality.)
Flags: needinfo?(tobi)

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.