LG HBS-700 Headset does not work with unagi

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g18-v1.0.0 affected)

Details

Attachments

(1 attachment)

Created attachment 708767 [details]
logcat

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/361d9359f4f3
Gaia   0abc95774d0bbdfe314fa588e09fc92cac3e6427
BuildID 20130130113326
Version 18.0
Unagi
  
## Repro :
1. connect the bluetooth headset with the device
2. press call button or play button

## Expected :
1. call would bring up the dialer app
2. play would start the music app

## Actual :
Nothing happens

## Note :
Dev Note: it's my own personal headset that I bought to test b2g/android with.  If you are out in the SFO, I can let you borrow it if you let me know ahead of time.
01-31 13:25:14.491: E/GeckoConsole(670): [JavaScript Error: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "RecentsDBManager is not defined" {file: "app://communications.gaiamobile.org/dialer/js/dialer.js" line: 116}]' when calling method: [nsIDOMSystemMessageCallback::handleMessage]" {file: "jar:file:///system/b2g/omni.ja!/components/SystemMessageManager.js" line: 76}]
The only thing that seems to work is the volume controling the ui for the bluetooth volume; the problem is there's no sound coming out of the bluetooth headset.
Also to note: this might go down a slippery slope for bluetooth headset testing... 
What's the minimum/maximum support for blue tooth devices?

For headset?
For file transfer?

I think we might need a product call for this portion.
(In reply to Naoki Hirata :nhirata from comment #2)
> 01-31 13:25:14.491: E/GeckoConsole(670): [JavaScript Error:
> "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error:
> "RecentsDBManager is not defined" {file:
> "app://communications.gaiamobile.org/dialer/js/dialer.js" line: 116}]' when
> calling method: [nsIDOMSystemMessageCallback::handleMessage]" {file:
> "jar:file:///system/b2g/omni.ja!/components/SystemMessageManager.js" line:
> 76}]

Hi Naoki,

I assume that your bluetooth headset sent out "BLDN" command (redial) when you press the call button, however, there's no call history in RecentsDBManager. That's why you get this Javascipt error. Can you try to make a call first before pressing the call button? Thanks!
(In reply to Naoki Hirata :nhirata from comment #3)
> The only thing that seems to work is the volume controling the ui for the
> bluetooth volume; the problem is there's no sound coming out of the
> bluetooth headset.

Please see the FAQ page in the following page:
https://wiki.mozilla.org/B2G/Bluetooth

For v1, HFP, HSP, and OPP is supported, and you should be able to hear sound from bluetooth headset only during a call. For music part, please see the first question in our FAQ. Thanks.
Flags: needinfo?(nhirata.bugzilla)
Want to make sure everyone knows that Shira is targeting 2/15 code freeze. 
Shira+ bugs needs more attention for unassigned, needinfo?,  review?
Full regression test is planned on 2/6. Need to have shira+ bugs landed by the end of 2/5 to be covered in full regression testing. Thanks
Yes, thanks for that information.
Bug 827399 tracks music over bluetooth.
- I take it that the rewind/fast forward buttons should not be functional as well?

Also: I still received this message after dialing and then closing the dialer app in task manager.  Does the RecentsDBManager shutdown when the dialer is closed?  

02-01 09:15:34.028: E/GeckoConsole(1296): [JavaScript Error: "RecentsDBManager is not defined" {file: "app://communications.gaiamobile.org/dialer/js/dialer.js" line: 116}]
02-01 09:15:34.038: E/GeckoConsole(1296): [JavaScript Error: "NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: '[JavaScript Error: "RecentsDBManager is not defined" {file: "app://communications.gaiamobile.org/dialer/js/dialer.js" line: 116}]' when calling method: [nsIDOMSystemMessageCallback::handleMessage]" {file: "jar:file:///system/b2g/omni.ja!/components/SystemMessageManager.js" line: 76}]
02-01 09:15:45.650: I/IdleService(108): Remove idle observer 47560b70 (1 seconds)
Flags: needinfo?(nhirata.bugzilla)
To note: Bluetooth device does redial after having the dialer up and making a call first.
seems to be working as expected. closing
Status: NEW → RESOLVED
blocking-b2g: shira? → ---
Last Resolved: 5 years ago
tracking-b2g18: ? → ---
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.