Closed Bug 837034 Opened 7 years ago Closed 7 years ago

Switch MediaStream interfaces to WebIDL

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla21

People

(Reporter: roc, Assigned: roc)

References

Details

Attachments

(2 files, 1 obsolete file)

No description provided.
Attachment #709903 - Flags: superreview?(peterv)
Attachment #709903 - Flags: review?(rjesup)
Attachment #709897 - Flags: review?(rjesup) → review+
Comment on attachment 709903 [details] [diff] [review]
Part 2: Convert DOMMediaStream to use WebIDL

Review of attachment 709903 [details] [diff] [review]:
-----------------------------------------------------------------

r- as it appears to be entirely a dup of patch1....

::: content/html/content/public/nsHTMLMediaElement.h
@@ +18,5 @@
>  #include "nsIObserver.h"
>  #include "AudioStream.h"
>  #include "VideoFrameContainer.h"
>  #include "mozilla/CORSMode.h"
> +#include "DOMMediaStream.h"

isn't this a duplicate of stuff from patch 1?
Attachment #709903 - Flags: review?(rjesup) → review-
Attached patch real Part 2Splinter Review
Attachment #709903 - Attachment is obsolete: true
Attachment #709903 - Flags: superreview?(peterv)
Attachment #714278 - Flags: review?(rjesup)
Attachment #714278 - Attachment is patch: true
Attachment #714278 - Flags: review?(rjesup) → review+
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 18 Branch → Trunk
https://hg.mozilla.org/mozilla-central/rev/c34f0e0628ad
https://hg.mozilla.org/mozilla-central/rev/2512bb04bbe0
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
You need to log in before you can comment on or make changes to this bug.