Closed Bug 837057 Opened 9 years ago Closed 9 years ago

"Segoe UI Light" font lookup fails on Windows, despite font's existence

Categories

(Core :: Layout: Text and Fonts, defect)

21 Branch
x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 835204

People

(Reporter: z-systems, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20130131 Firefox/21.0
Build ID: 20130131031009

Steps to reproduce:

Specify "Segoe UI Light" as the font-family in CSS.


Actual results:

The font lookup fails and Firefox falls back to the next font in the font-family list or to the default font if none were specified.


Expected results:

In keeping compatibility with other browsers, Firefox should be able to find "Segoe UI Light" since it is installed by default on all Windows systems. The reason it currently doesn't find it is that the real font-family is "Segoe UI" and web developers are meant to specify a font-weight if they want to specify a lighter version. However, IE, Chrome, and Opera all look it up properly. For parity with others, and to increase compatibility with pages in the wild, I think sub-font names should be supported in the font-family field.
Component: Untriaged → Layout: Text
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 835204
You need to log in before you can comment on or make changes to this bug.